Test: lua-5.4.3-3

Lemures Lemniscati lemures.lemniscati@gmail.com
Sat Jun 5 22:36:53 GMT 2021


The following packages have been uploaded to the Cygwin distribution:

* lua-5.4.3-3
* liblua5.3-5.4.3-3
* liblua-devel-5.4.3-3

* lua-5.4.3-3-src
* lua-debuginfo-5.4.3-3

Added workaround to postinstall/preremove scripts
in case CYGWIN=winsymlinks:nativestrict is specified.

--
Lua is a powerful, light-weight programming language designed for extending
applications. Lua is also frequently used as a general-purpose, stand-alone
language.

--

Cygwin Changes from lua-5.4.3-2

Added a workaround to postinstall/preremove scripts
in case CYGWIN=winsymlinks:nativestrict is specified.

In such cases, postinstall/preremove scripts temporarily override
CYGWIN with CYGWIN="${CYGWIN} winsymlinks:native" [1]. And comments
about it are printed, so that we can see them in 'setup.full.log'.

[1]: https://www.cygwin.com/git-cygwin-packages/?p=git/cygwin-packages/lua.git;a=blob;f=winsymlinks-nativestrict.sh;hb=969f89bfe6c2d39016c9e8f2692188de0e1c3461

Note: From lua-5.4.3-1, some files come with version number:
 e.g: lua5.4.exe, which is symlinked from lua by alternatives.

Note: Modules for Lua 5.4 is not prepared yet.
  This is just a TEST of the interpreter/compiler.

Lemures Lemniscati



More information about the Cygwin-announce mailing list