Updated: parrot-2.2.0-1 New: rakudo-201003-1 (aka perl6)

Reini Urban rurban@x-ray.at
Fri Apr 16 18:02:00 GMT 2010


I updated the parrot and rakudo packages from 0.8.2 to 2.2.0-1 in the 
Cygwin distribution. rakudo switched to date versioning for the monthly 
releases, so that's 201003 now, the april release on the horizon.

This is not from any branch of mine anymore, with only minimal patches.

Canonical homepage:
   http://www.parrot.org/

Canonical download:
   http://www.parrot.org/release/current

My repo:
 
http://code.google.com/p/cygwin-rurban/source/browse/#svn/trunk/release/parrot

I had most of the missing parrot and perl6 packages between 0.8.2 and 
2.2.0 ready and uploaded some to my server, but decided not to release 
it until now for the following reason.
* My previous parrot packages could be installed easily, that means you 
didn't need to download from svn and build from source to create or 
maintain any other language. Most of these patches weren't accepted 
upstream, parrot decided somewhen to install needed -devel files into 
/usr/src/parrot possibly overwriting the parrot src package downloaded 
via the cygwin package. I gave up on this now.
* pbc_compat was given up. That's why I stepped down as committer. 
Something is planned for 3.0 though.

There are so many news since 0.8.2, please swift through the various 
Release Notes at http://www.parrot.org/category/news/news.
It got not faster though, had a massive step in passing perl6 spec tests 
(http://www.rakudo.org/status), many more features were added, some removed.

Note that parrot-2.2 is API-wise unstable.
I did not get rakudo matching the last *stable* parrot 2.0 working, so I 
went to 2.2 instead, which worked.

parrot-languages is gone. Previously I tried to keep up with parrot-pipp 
but that needed massive parrot patches. Only rakudo went up to be 
installable. The former languages are not in the parrot svn repo 
anymore, so they need seperate package and releases anyway. I'll try to 
keep up adding prominent languages when the opportunity arises. But 
since the pbc format is not forwards and backwards compatible and 
changes often, you need the exact matching parrot release. This will be 
tricky.

Packaging Details:
* I obsoleted libparrot0 and libparrot-devel and went to the simplier 
layout parrot and parrot-devel.
* parrot-devel installs into /usr/src/parrot/<VERSION>. Do not delete 
this if you want to compile languages, like perl6.

=====================================================================

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Once you've downloaded setup.exe, run it and select "Editors"
or "Text" and then click on the appropriate fields until the above
announced version numbers appear if they are not displayed already.

If your mirror doesn't yet have the latest version of this package after
24 hours, you can either continue to wait for that site to be updated or
you can try to find another mirror.

Please send questions or comments to the Cygwin mailing list at:
cygwin@cygwin.com

If you want to subscribe go to:
http://cygwin.com/ml/cygwin/

I would appreciate if you would use this mailing list rather than
emailing me directly.  This includes ideas and comments about the setup
utility or Cygwin in general.

If you want to make a point or ask a question the Cygwin mailing
list is the appropriate place.

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin-announce mailing list