Updated: {terminfo/terminfo-extra/termcap}-5.7_20091114-3

Charles Wilson cygwin@cwilson.fastmail.fm
Sat Nov 28 18:13:00 GMT 2009


The terminfo packages contain the terminal information database that
enables proper operation of ncurses-based applications. The termcap
package provides an obsolete, backwards-compatible format that
contains similar information, for a few selected terminal types.

This package provides the terminfo database using the arrangement
expected by the libncurses9 (and later) libraries. Older applications
which use the legacy libncurses8 library will use the data provided
by the terminfo0 backwards-compatibility database. Both terminfo and
terminfo0 may be installed simultaneously. Even OLDER applications
that use the obsolete /etc/termcap database are supported by the
new termcap sub-package (see changes, below).

The terminfo package contains most of the terminal definitions commonly
used on the cygwin platform, and a selection of others. The terminfo-extra
package provides all of the others.

CHANGES since terminfo-5.7_20090228
===================================
o Update to 20091114 patchset from ncurses

o Add termcap subpackage, replacing the pre-existing standalone
  version.  termcap has been deprecated, so the standalone
  package, which provided not just /etc/termcap, but also

	/usr/include/termcap.h
	/usr/lib/libtermcap.a
	/usr/share/man/man3/termcap.3

  has been removed. For backwards compatibility, an updated
  version of /etc/termcap is provided here, but the development
  files are not: newly compiled applications should use terminfo
  (that is, libncurses) and not libtermcap.

o /etc/termcap now provides hicolor variants of putty, xterm,
  rxvt, and screen.

o /etc/termcap no longer provides the following entries and aliases,
  which were never supported by terminfo anyway and were therefore
  almost certainly broken, in practice:
  Removed Entries:
    other           (use 'unknown')
    arpanet|bussiplexer|dialup|ethernet|network|net|patch|plugboard|switch
                    (use 'unknown')
    pcansi-mono25   (use 'pcansi25m' terminfo; no termcap repl. provided)
    pcansi-mono33   (use 'pcansi33m' terminfo; no termcap repl. provided)
    pcansi-mono43   (use 'pcansi43m' terminfo; no termcap repl. provided)
    linux-mono      (use 'linux-m' terminfo; no termcap repl. provided)
  Removed Aliases:
    print           (use 'lpr' instead)
    printing        (use 'lpr' instead)
    SC              (use 'screen' instead)
    SH              (use 'screen-s' instead)
    SB              (use 'screen-bce' instead)
    ansisys         (use 'ansi.sys' instead)
    ansi25          (use 'pcansi-25' instead)
    ansi33          (use 'pcansi-33' instead)
    ansi43          (use 'pcansi-43' instead)
    ansi-pc-color   (use 'klone+color' instead)

-- 
Charles Wilson
volunteer terminfo maintainer for cygwin

====================================================================

To update your installation, click on the "Install Cygwin now" link
on the http://cygwin.com/ web page.  This downloads setup.exe to
your system.  Then, run setup and answer all of the questions.

              *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com@cygwin.com

If you need more information on unsubscribing, start reading here:

http://sourceware.org/lists.html#unsubscribe-simple

Please read *all* of the information on unsubscribing that is
available starting at this URL.



More information about the Cygwin-announce mailing list