[1.7] Updated: perl-5.10.1-1

Reini Urban rurban@x-ray.at
Sat Dec 5 09:50:00 GMT 2009


perl has been updated to 5.10.1-1 for the upcoming cygwin -1.7 release.

Important Changes since the last perl-5.10.0-5:
   - for cygwin-1.7 and gcc-4 only
   - added Win32CORE to the dll to enable libtool compilation (Yaakov).
     This is a fragile hack but survived all attempts to break it so far.

perl-5.10 cygwin notes:
-------------------------

This release is binary incompatible with the old 5.8 releases,
but compatible to all 5.10.x releases. That's why we named the main
perl DLL /bin/cygperl5_10.dll and not cygperl5_10_0.dll.

The requirements for the special perl link driver ld2 and perlld had
been removed.

Cygwin mount point information is now accessible, esp. text/binary
detection.

Some modules have been added to vendor_perl, but most of the old vendor
modules moved to CORE.
Included are Bundle::CPAN, CPAN::Reporter, XML::LibXML and several
Test modules.
Note: Installed modules (e.g. via CPAN) in site_perl have higher
precedence than vendor_perl modules. So you can easily update these via 
CPAN.

See http://www.perl.org/
ChangeLog:     http://perldoc.perl.org/perldelta.html
Cygwin README: http://perldoc.perl.org/perlcygwin.html

Vendor patches for 5.10.1-1:
* CYG11 Empty .bs files are not generated anymore
* CYG12 no archlib in otherlibdirs
* CYG14 Dynaloader
* CYG15 static-Win32CORE
* CYG17 utf8-paths
* CYG21 LibList-Kid.patch
* CYG22 cygwin-1.7 hints
* CYG23 544-stat
* CYG24 build man pages
* Bug#55162 File::Spec::case_tolerant performance
* disable ExtUtils::MakeMaker::Coverage in Sys-Syslog

The patch "CYG25 use same image-base when exchanging privlib dlls" was 
reverted as it was too fragile. This means that updating core modules 
into arch might still require a rebaseall, esp. the Compress::Raw modules.


Update recommendations from 5.8:
-------------------------------

Since 5.10 is not installed in parallel to 5.8 (it is possible, but not
with this package), all your old 5.8 modules will need to be reinstalled
for 5.10.
Your old 5.8 modules are not deleted, just not accessible to 5.10.
Non-binary packages can be used by adding /usr/lib/perl5/site_lib/5.8 to
your @INC, but the below procedure is recommended to get the latest
version for each installed package.
This will not harm most of your previous 5.8 modules in case you want to
switch back to 5.8, just the /bin scripts might get overwritten.

BEFORE INSTALLATION of 5.10 !
# get the list of installed 5.8 modules
$ perl -MExtUtils::Installed \
   -e'print join("\n", new ExtUtils::Installed->modules)' > module.list

AFTER INSTALLATION of 5.10 !
# install all previous modules for 5.10
$ cpan `cat module.list`


Detailed NEWS from README
-------------------------
5.10.1-1
   - first cygwin-1.7 release, with gcc-4. Binary incompatible to any
     cygwin-1.5 perl-5.10.0 release.
   - added CYG23-544-stat.patch to fix a -w stat() if being a member of
     the group 544 Administrators.
   - added CYG24-man.patch to generate man pages for ExtUtils::MakeMaker
     modules. Accessing the section 3 pages this will need a man update.
   - prepared a debuginfo package with the symbols exported to
     /usr/lib/debug, but the symbols are NOT picked by gdb yet.
   - forced chmod +x usr/bin/*
   - vendor_perl modules added:
     Net-IP-1.25 Text-Glob-0.08 Number-Compare-0.01 File-Find-Rule-0.30
     Data-Compare-1.2101 CPAN-Checksums-2.02 File-Remove-1.42
     File-chmod-0.32
     Params-Util-1.00 Test-Script-1.03 CPAN-Inject-0.11 Socket6-0.23
     IO-Socket-INET6-2.56
   - vendor_perl modules updated:
     Pod-Simple-3.08 Test-Pod-1.40 Pod-Coverage-0.20
     Compress-Raw-Bzip2-2.021 IO-Compress-2.021 File-Temp-0.22
     Archive-Zip-1.30
     Term-ReadLine-Gnu-1.19 XML-NamespaceSupport-1.10 XML-SAX-0.96
     XML-LibXML-1.69
     Proc-ProcessTable-0.45 YAML-0.70 File-Copy-Recursive-0.38
     IPC-Run3-0.043
     IO-CaptureOutput-1.1101 File-HomeDir-0.86
   - installsitescript and installsitebin changed from /usr/bin to
     /usr/local/bin

========================================================================

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.

                *** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-you=yourdomain.com@cygwin.com

If you need more information on unsubscribing, start reading here:

http://sources.redhat.com/lists.html#unsubscribe-simple

Please read *all* of the information on unsubscribing that is available
starting at this URL.




More information about the Cygwin-announce mailing list