[New packages] db-4.5.20-1/libdb4.5-4.5.20-1/libdb4.5-devel-4.5.20-1 - Oracle Berkeley DB

Dr. Volker Zell dr.volker.zell@oracle.com
Fri Jul 13 12:55:00 GMT 2007


Hi

The packages db-4.5.20-1/libdb4.5-4.5.20-1/libdb4.5-devel-4.5.20-1 are now 
available with the Cygwin distribution:

 o http://www.oracle.com/technology/products/berkeley-db/db/index.html (Homepage)


DESCRIPTION:
============

Oracle Berkeley DB is the industry-leading open source, embeddable 
database engine that provides developers with fast, reliable, local persistence 
with zero administration. Oracle Berkeley DB is a library that links directly 
into your application. Your application makes simple function calls, rather than 
sending messages to a remote server, eliminating the performance penalty of 
client-server architectures. Oracle Berkeley DB eliminates the overhead of SQL query 
processing, enabling applications with predictable access patterns to run 
faster.


With this version comes a maintainer switch. Gerrit P. Haase used to maintain the 
old Berkeley DB packages. 

The package consist of three packages:

1. `db' contains the documentation.
2. `libdb4.5' contains the runtime libraries.
3. `libdb4.5-devel' contains import libraries and headers as
   well as the utility executables (db_dump, db_load, ...).


Different versions of DB may be installed at the same time using
setup.exe, however the symlinks needed to link against libdb will be
removed by the postinstall script and the last installed libdb-devel
package will be the one found by the linker when using -ldb on the
linker command line.

The following symlinks are created by the postinstall libdb4.5-devel.sh script:

  /usr/bin/db_archive.exe    ---> db4.5_archive.exe
  /usr/bin/db_checkpoint.exe ---> db4.5_checkpoint.exe
  /usr/bin/db_deadlock.exe   ---> db4.5_deadlock.exe
  /usr/bin/db_dump.exe       ---> db4.5_dump.exe
  /usr/bin/db_hotbackup.exe  ---> db4.5_hotbackup.exe
  /usr/bin/db_load.exe       ---> db4.5_load.exe
  /usr/bin/db_printlog.exe   ---> db4.5_printlog.exe
  /usr/bin/db_recover.exe    ---> db4.5_recover.exe
  /usr/bin/db_stat.exe       ---> db4.5_stat.exe
  /usr/bin/db_upgrade.exe    ---> db4.5_upgrade.exe
  /usr/bin/db_verify.exe     ---> db4.5_verify.exe
  /usr/include/db.h          ---> db4.5/db.h
  /usr/include/db4/          ---> db4.5/
  /usr/lib/libdb.a           ---> libdb-4.5.a
  /usr/lib/libdb.la          ---> libdb-4.5.la
  /usr/lib/libdb.dll.a       ---> libdb-4.5.dll.a
  /usr/lib/libdb_cxx.a       ---> libdb_cxx-4.5.a
  /usr/lib/libdb_cxx.la      ---> libdb_cxx-4.5.la
  /usr/lib/libdb_cxx.dll.a   ---> libdb_cxx-4.5.dll.a


If you have previously installed an older version of this library, and 
after installation of the new version you need the old symlinks, reexecute
the version-dependent /etc/postinstall/libdb<version>-devel.sh script.

Eventually the Berkeley DB packages will be repackaged to use 
alternatives.


NEWS:
=====

Requires log file format upgrade.

The on-disk log file format changed in the Berkeley DB 4.5 release.
For further information on upgrading Berkeley DB installations, see
'Upgrading Berkeley DB installations':
file:///usr/share/doc/db-4.5.20/docs/ref/upgrade/process.html

A detailed Changelog is available online at the Oracle Berkeley DB
website: 

http://www.oracle.com/technology/software/products/berkeley-db/db/index.html



Packages which could potentially be updated: (according to setup.ini)
=====================================================================

aprutil1         -> libdb4.2-devel
clisp            -> libdb4.3
gnome-libs-devel -> libdb4.3-devel
libaprutil0      -> libdb4.2
libaprutil1      -> libdb4.2
libsasl2         -> libdb4.2
libsasl2-devel   -> libdb4.2             ??? Is this right
perl             -> libdb4.2, libdb4.3   uses tow different versions
python           -> libdb4.2
subversion       -> libdb4.2
xemacs           -> libdb4.3



Enjoy
    Volker

--

To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Once you've downloaded setup.exe, run it and select "Database" or "Libs"
and then click on the appropriate fields until the above announced
version numbers appear if they are not displayed already.

If your mirror doesn't yet have the latest version of this package after
24 hours, you can either continue to wait for that site to be updated or
you can try to find another mirror.

Please send questions or comments to the Cygwin mailing list at:
cygwin@cygwin.com

If you want to subscribe go to:
http://cygwin.com/ml/cygwin/

I would appreciate if you would use this mailing list rather than
emailing me directly.  This includes ideas and comments about the setup
utility or Cygwin in general.

If you want to make a point or ask a question the Cygwin mailing
list is the appropriate place.



More information about the Cygwin-announce mailing list