Updated [test]: postgresql-8.1.4-2

Reini Urban rurban@x-ray.at
Sun Jul 30 14:47:00 GMT 2006


The latest and greatest postgresql-8.1.4-2 is released via the cygwin
setup.exe mirror network. As experimental test version, because of the
layout change.

What's new / How to upgrade:
   http://www.postgresql.org/docs/whatsnew (for 8.1)
   http://www.postgresql.org/docs/8.1/static/release.html#RELEASE-8-1-4

Before you upgrade a postgresql package to a new new major or
minor version (7.4 => 8.0 => 8.1), be sure to dump all your data before!
With the new package you will not be able to access your old databases.
=> http://www.postgresql.org/docs/8.0/static/app-pg-dumpall.html
Minor subrelease updates (e.g. 8.0.4 to 8.0.7, or 8.1.3 to 8.1.4) can
safely access the same database.

Be sure to read the README.cygwin and the postgresql documentation.

I recommend to install the new 8.1 right away, available as [test]
version from setup, and skip 8.0 altogether. 8.1 has major feature
improvements over 8.0, esp. when you use tsearch2 and PostGIS:
crash-recovery on GiST indices, improved concurrency.

I'll keep 8.0 a while as curr until the new layout with
postgresql-8.1.4-2 is appreciated. The upcoming 8.1.5 will be curr soon.
The 7.4.x server is dropped now.
You can talk to 7.4.x servers via the libpq API in the new libpq3
package (pq.dll). You may build 7.4 client binaries from the libpq3 src
package.

The new packages are named as in debian, except that we don't support
multiple server and client versions side-by-side. client libs we do.

postgresql 		the server
postgresql-client 	the client binaries
postgresql-contrib	server extensions
postgresql-devel	Header files for compiling SSI code to link into
PostgreSQL's backend; for example, for C functions to be called
	from SQL. This package also contains the Makefiles necessary for
	building add-on modules of PostgreSQL, which would otherwise
	have to be built in the PostgreSQL source-code tree. (slony,
	postgis, ...)
postgresql-doc		
postgresql-plperl	
postgresql-plpython	
libpq4			cygpq.dll for 8.0/8.1
libpq-devel
libecpg5		run-time library for ECPG programs -
			Embedded PostgreSQL for C
libpgtypes2		cygpgtypes.dll for 8.0/8.1 - for ECPG only
libpgtypes1		shared library pgtypes.dll for PostgreSQL 7.4.x
			for ECPG only
libecpg-compat2		cygecpg_compat.dll for 8.0.x
libecpg-devel
libpq3			pq.dll for 7.4.x
libecpg4		ecpg.dll for 7.4.x
libecpg_compat1		ecpg_compat.dll for 7.4.x

I've also created various backwards compatible libpq's:
libpgtypes1-7.4.5-1
libecpg4-7.4.5-1
libecpg-compat1-7.4.5-1
libpq3-7.4.5
libpq4-8.0.7
postgresql-client-8.0.7-1 (empty!)


Please ask questions here at <cygwin@cygwin.com>,
and only if you really have to, over at <pqsql-cygwin@postgresql.org>.
-- 
Reini Urban
http://phpwiki.org/  http://murbreak.at/
http://helsinki.at/  http://spacemovie.mur.at/



More information about the Cygwin-announce mailing list