Building rpi armv6 toolchain on macOS

Etan Kissling
Sun Mar 12 12:14:00 GMT 2017

Got me :-)

With bundled patches and master, it runs through for me now as well, even without my original changes.
The oldconfig was the only step I missed ^^ Thanks for pointing out my mistake there!

> On 12 Mar 2017, at 02:04, Alexey Neyman <> wrote:
> On 03/11/2017 04:03 PM, Josh Branning wrote:
>> On 11/03/17 21:06, Etan Kissling wrote:
>>> Thanks for the quick reply!
>>> With the master build, I run into an error quite quickly (following instructions from
>>> [DEBUG]  ==> Executing: 'mkdir' '-p' '/build'
>>> [ALL  ]  mkdir: /build: Permission denied
>>> - Full log:
>>> Any idea what's going on here?
>> Are you running crosstool-ng as root? And do you have permission to write to the / directory? I'm guessing not. (If not, then I suggest changing the build directory instead of running as root.)
> As the error states, he *is not* running it as root. Moreover, running as root IS NOT RECOMMENDED - crosstool-ng is quite explicit about it.
> The problem is that he took a config from 1.22 and tried to run it on master without upgrading it through the regular procedure for kconfig-based system ("oldconfig"). In master, build directory is set using a value of an auxiliary variable, CT_BUILD_TOP_DIR, that isn't set in the config unless it is upgraded.
> Regards,
> Alexey.

More information about the crossgcc mailing list