ct-ng fails in building cloog

Jasmin J. jasmin@anw.at
Fri Sep 4 07:45:00 GMT 2015

Hi Vania!

> /.build/src/cloog-0.18.1/source/isl/domain.c:799:2: error: unknown type name
> 'isl_int'
I had exactly the same error for my arm-none-eabi built. I dropped down the isl
version to 0.12.2, which solved the issue.
I had no time to track it down, but maybe you have ;)



On 09/03/2015 06:00 PM, Vania Joloboff wrote:
> Hi
> I am a newbie to ct-ng but I have long been building cross compilers.
> I just downloaded ct-ng 1.21.0
> I tried first with the ARM sample from the list.
> It worked fine. I tested the generated compiler and it works fine.
> Next, I tried my own config with menuconfig for a PowerPC
> target using EABI on bare metal.
> No problem with the configuration.
> But when I build, it builds GMP, MPFR, ISL but then it fails
> in building CLooG with error
> /.build/src/cloog-0.18.1/source/isl/domain.c:799:2: error: unknown type name
> 'isl_int'
> I checked : the isl_int type is defined in file include/isl_int.h
>  as an equivalent type to GMP type with comment
> /* isl_int is the basic integer type.  It currently always corresponds
>  * to a gmp mpz_t, but in the future, different types such as long long
>  * or cln::cl_I will be supported.
>  */
> typedef mpz_t    isl_int;
> So it should compile... Any help appreciated.
> I would really love to use ct-ng instead of maintaining my own script...
> Cheers
> -vj
> -- 
> For unsubscribe information see http://sourceware.org/lists.html#faq

For unsubscribe information see http://sourceware.org/lists.html#faq

More information about the crossgcc mailing list