Building for ARM a8/Beaglebone Black on OS X 10.11 (El Capitan) and newbie questions

Joe Ciarcia
Wed Oct 28 20:10:00 GMT 2015

I'm wondering if anyone has been successful building toolchains on El
Capitan? I'm attempting to build a toolchain for a BeagleBone Black
from a Mac running El Cap. I'm running into a few roadblocks. Here's
where I'm at:

I started here:

ct-ng arm-cortex_a8-linux-gnueabi

... and used this as a guide to check some of the settings:

ct-ng seems to have an option for building autoconf so instead of
following the workarounds for that, I tried that (in Companion Tools)

A few answers I couldn't find with Professor Google...
* The kernel version is 3.8.13 (Debian distro for the BeableBone
Black). In the menuconfig under Linux Kernel Version, I'm not seeing
that as an option. Can I just get away  with entering the previous
version (3.4.107)?

Moving on... running ct-ng build for the first time I get this...

[DEBUG]  =================================================================
[DEBUG]  Checking that gcc can compile a trivial program
[DEBUG]    ==> Executing: 'x86_64-build_apple-darwin15.0.0-gcc' '-O2'
'-g' '-pipe' '/Volumes/CaSe/build/arm-cortex_a8-linux-gnueabi/build/test.c'
'-o' '/Volumes/CaSe/build/arm-cortex_a8-linux-gnueabi/build/.gccout'
[DEBUG]  Checking that gcc can compile a trivial program: done in
0.00s (at 00:03)
[EXTRA]  Installing user-supplied crosstool-NG configuration
[DEBUG]  ==> Executing: 'mkdir' '-p' '/Volumes/CaSe/prefix/bin'
[DEBUG]  ==> Executing: 'install' '-m' '0755'
[DEBUG]  /Volumes/CaSe/build/tools/bin/install: line 2: exec:
ginstall: not found

My solution was to just copy install to ginstall in the
.build/tools/bin directory. That gets me past that point if I run the
build again.

[INFO ]  Performing some trivial sanity checks
[INFO ]  Build started 20151028.143057
[INFO ]  Building environment variables
[EXTRA]  Preparing working directories
[EXTRA]  Installing user-supplied crosstool-NG configuration
[00:03] /

... and then "nothing" happens (the terminal doesn't update at all).
Well, not nothing. If I look at the activity monitor processor
utilization under bash is near 100% on one of the cores so clearly
it's doing "something". Unfortunately it doesn't seem to produce
results of any kind. I've left it for 12 hours which I figure should
have been more than enough time before killing the process. At that
point, the last line in the build.log file is this:

DEBUG]  ==> Executing: 'install' '-m' '0755'

The full build.log is here:

 Unfortunately I'm not sure what I should be looking for as this just
runs the process near 100% indefinitely and I never see any errors or
warnings printed out to the log. Any ideas?

Cheers, Joe

For unsubscribe information see

More information about the crossgcc mailing list