bug in crosstool-ng-1.21.0-43-gbaceedd?

Aaron M. enzymatic.bubble@gmail.com
Fri Jun 19 06:43:00 GMT 2015


I think I found a bug in crosstool-ng-1.21.0-43-gbaceedd. I definitely
don't understand everything that's going on, so it may have been a
problem elsewhere.

When I followed the instructions on
http://archlinuxarm.org/developers/distcc-cross-compiling (I
downloaded the v7 config), I ran into this problem (see bad-build.txt

I fixed it by adding
CT_CC_GCC_VERSION="4.9.2" to the bin/.config file. Previously, there
was only CT_CC_VERSION, which wasn't recognized apparently.

I hope this helps! Please let me know if you have any questions. :)

-------------- next part --------------
$ ./ct-ng build
[INFO ]  Performing some trivial sanity checks
[INFO ]  Build started 20150618.230840
[INFO ]  Building environment variables
[WARN ]  Directory '/home/x/cross/src' does not exist.
[WARN ]  Will not save downloaded tarballs to local storage.
[EXTRA]  Preparing working directories
[EXTRA]  Installing user-supplied crosstool-NG configuration
[EXTRA]  =================================================================
[EXTRA]  Dumping internal crosstool-NG configuration
[EXTRA]    Building a toolchain for:
[EXTRA]      build  = x86_64-unknown-linux-gnu
[EXTRA]      host   = x86_64-unknown-linux-gnu
[EXTRA]      target = arm-unknown-linux-gnueabihf
[EXTRA]  Dumping internal crosstool-NG configuration: done in 0.05s (at 00:02)
[INFO ]  =================================================================
[INFO ]  Retrieving needed toolchain components' tarballs
[EXTRA]    Retrieving 'linux-3.18.1'
[EXTRA]    Retrieving 'gmp-6.0.0a'
[EXTRA]    Retrieving 'mpfr-3.1.2'
[EXTRA]    Retrieving 'isl-0.12.2'
[EXTRA]    Retrieving 'cloog-0.18.1'
[EXTRA]    Retrieving 'mpc-1.0.2'
[EXTRA]    Retrieving 'binutils-2.25'
[EXTRA]    Retrieving 'gcc-'
[ERROR]  >>
[ERROR]  >>  Build failed in step 'Retrieving needed toolchain components' tarballs'
[ERROR]  >>        called in step '(top-level)'
[ERROR]  >>
[ERROR]  >>  Error happened in: do_gcc_get[scripts/build/cc/100-gcc.sh@741]
[ERROR]  >>        called from: do_cc_get[scripts/build/cc.sh@21]
[ERROR]  >>        called from: main[scripts/crosstool-NG.sh@585]
[ERROR]  >>
[ERROR]  >>  For more info on this error, look at the file: 'build.log'
[ERROR]  >>  There is a list of known issues, some with workarounds, in:
[ERROR]  >>      '/home/x/dev/usb-armory/cross/share/doc/crosstool-ng/ct-ng.crosstool-ng-1.21.0-43-gbaceedd/B - Known issues.txt'
[ERROR]  (elapsed: 3:12.12)
[03:13] / ct-ng:147: recipe for target 'build' failed
make: *** [build] Error 1
-------------- next part --------------
For unsubscribe information see http://sourceware.org/lists.html#faq

More information about the crossgcc mailing list