Fail during Installing final compiler on a different machine

Claude Robitaille claudesailor@yahoo.ca
Mon Nov 24 01:42:00 GMT 2014


I do not know of a place to post it but I think the weird escaping is due to the fact that my original email was html formatted. The list bounced back and I resubmitted by doing a cut and paste.....

here it is again, afresh from the terminal. If you know of a place to post I will post it there.

Thanks


[ALL  ]    rm -f include-fixed/README
[ALL  ]    cp /home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc-4.5.2/gcc/../fixincludes/README-fixinc include-fixed/README
[ALL  ]    chmod a+r include-fixed/README
[ALL  ]    echo timestamp > stmp-int-hdrs
[ALL  ]    rm gcc.pod
[ALL  ]    make[3]: Leaving directory `/home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/i686-unknown-linux-gnu/build/build-cc/gcc'
[ALL  ]    Checking multilib configuration for libgcc...
[ALL  ]    mkdir -p -- i686-unknown-linux-gnu/libgcc
[ALL  ]    Configuring in i686-unknown-linux-gnu/libgcc
[ALL  ]    make[3]: Entering directory `/home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/i686-unknown-linux-gnu/build/build-cc/lto-plugin'
[ALL  ]    /bin/bash ./libtool --tag=CC   --mode=compile x86_64-build_unknown-linux-gnu-gcc -DPACKAGE_NAME="LTO plugin for ld" -DPACKAGE_TARNAME="lto-plugin" -DPACKAGE_VERSION="0.1" -DPACKAGE_STRING="LTO plugin for ld 0.1" -DPACKAGE_BUGREPORT="" -DPACKAGE_URL="" -DPACKAGE="lto-plugin" -DVERSION="0.1" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=".libs/" -I. -I/home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc-4.5.2/lto-plugin  -I/home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc-4.5.2/lto-plugin/../include -Ino/include -Ino/include/libelf  -Wall -Werror -pipe  -c -o lto-plugin.lo /home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc-4.5.2/lto-plugin/lto-plugin.c
[ALL  ]    libtool: compile:  x86_64-build_unknown-linux-gnu-gcc "-DPACKAGE_NAME="LTO plugin for ld"" -DPACKAGE_TARNAME="lto-plugin" -DPACKAGE_VERSION="0.1" "-DPACKAGE_STRING="LTO plugin for ld 0.1"" -DPACKAGE_BUGREPORT="" -DPACKAGE_URL="" -DPACKAGE="lto-plugin" -DVERSION="0.1" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=".libs/" -I. -I/home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc-4.5.2/lto-plugin -I/home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc-4.5.2/lto-plugin/../include -Ino/include -Ino/include/libelf -Wall -Werror -pipe -c /home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc-4.5.2/lto-plugin/lto-plugin.c  -fPIC -DPIC -o .libs/lto-plugin.o
[ALL  ]    libtool: compile:  x86_64-build_unknown-linux-gnu-gcc "-DPACKAGE_NAME="LTO plugin for ld"" -DPACKAGE_TARNAME="lto-plugin" -DPACKAGE_VERSION="0.1" "-DPACKAGE_STRING="LTO plugin for ld 0.1"" -DPACKAGE_BUGREPORT="" -DPACKAGE_URL="" -DPACKAGE="lto-plugin" -DVERSION="0.1" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=".libs/" -I. -I/home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc-4.5.2/lto-plugin -I/home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc-4.5.2/lto-plugin/../include -Ino/include -Ino/include/libelf -Wall -Werror -pipe -c /home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc-4.5.2/lto-plugin/lto-plugin.c -o lto-plugin.o >/dev/null 2>&1
[ALL  ]    /bin/bash ./libtool --tag=CC   --mode=link x86_64-build_unknown-linux-gnu-gcc -Wall -Werror -pipe    -o liblto_plugin.la -rpath /home/crobitaille/sbox/private/trunk2.image/i686-32/bin/x-tools/libexec/gcc/i686-unknown-linux-gnu/4.5.2 lto-plugin.lo -Lno/lib -lelf ../libiberty/pic/libiberty.a 
[ALL  ]    configure: creating cache ./config.cache
[ALL  ]    checking for --enable-version-specific-runtime-libs... no
[ALL  ]    checking for a BSD-compatible install... /home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/tools/bin/install -c
[ALL  ]    checking for gawk... gawk
[ALL  ]    checking build system type... x86_64-build_unknown-linux-gnu
[ALL  ]    checking host system type... ./libtool: line 5195: cd: no/lib: No such file or directory
[ALL  ]    libtool: link: cannot determine absolute directory name of `no/lib'
[ERROR]    make[3]: *** [liblto_plugin.la] Error 1
[ALL  ]    make[3]: Leaving directory `/home/crobitaille/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/i686-unknown-linux-gnu/build/build-cc/lto-plugin'
[ERROR]    make[2]: *** [all-lto-plugin] Error 2
[ALL  ]    make[2]: *** Waiting for unfinished jobs....
[ALL  ]    i686-unknown-linux-gnu
[ALL  ]    checking for i686-unknown-linux-gnu-ar... /home/crobitaille/sbox/private/trunk2.image/i686-32/bin/x-tools/i686-unknown-linux-gnu/bin/ar


 


On Sunday, November 23, 2014 7:48 PM, Bryan Hundven <bryanhundven@gmail.com> wrote:
Claude,




On Sun, Nov 23, 2014 at 1:33 PM, Claude Robitaille
<claudesailor@yahoo.ca> wrote:
> I guess the emails on this list=C2=A0 always start by I am trying to build
> a cross tool but fail.... but in my case there is a little difference.
> I have a working config that works just fine on one Ubuntu 12.04 but
> not on another same Ubuntu 12.04.... :-( I am guessing a dependency
> not met somehow.
>
> On the failing machine, the build works fine until the Installing
> final version. Here is the excerpt from build.log:
>
>
> [ALL=C2=A0 ]=C2=A0 =C2=A0 libtool: compile:=C2=A0 x86_64-build_unknown-linu=
> x-gnu-gcc
> "-DPACKAGE_NAME=3D3D"LTO plugin for ld"" -DPACKAGE_TARNAME=3D3D"lto-plugin"
> -DPACKAGE_V
> ERSION=3D3D"0.1" "-DPACKAGE_STRING=3D3D"LTO plugin for ld 0.1""
> -DPACKAGE_BUGREPORT=3D3D"" -DPACKAGE_URL=3D3D"" -DPACKAGE=3D3D"lto-plugin"
> -DVERSION=3D3D"0.1" -DSTDC_HE
> ADERS=3D3D1 -DHAVE_SYS_TYPES_H=3D3D1 -DHAVE_SYS_STAT_H=3D3D1 -DHAVE_STDLIB_=
> H=3D3D1
> -DHAVE_STRING_H=3D3D1 -DHAVE_MEMORY_H=3D3D1 -DHAVE_STRINGS_H=3D3D1
> -DHAVE_INTTYPES_H=3D3D1 -D
> HAVE_STDINT_H=3D3D1 -DHAVE_UNISTD_H=3D3D1 -DHAVE_DLFCN_H=3D3D1
> -DLT_OBJDIR=3D3D".libs/" -I.
> -I/home/xxx/sbox/private/trunk2.image/i686-32/bin/cross-tool
> /.build/src/gcc-4.5.2/lto-plugin
> -I/home/xxx/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc=
> =3D
> -4.5.2/lto-plugin/../include
> =C2=A0-Ino/include -Ino/include/libelf -Wall -Werror -pipe -c
> /home/xxx/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/src/gcc-4=
> =3D
> .5.2
> /lto-plugin/lto-plugin.c -o lto-plugin.o >/dev/null 2>&1
> [ALL=C2=A0 ]=C2=A0 =C2=A0 /bin/bash ./libtool --tag=3D3DCC=C2=A0 =C2=A0--mo=
> de=3D3Dlink
> x86_64-build_unknown-linux-gnu-gcc -Wall -Werror -pipe=C2=A0 =C2=A0 -o
> liblto_plugin.la=C2=A0-rpath /home
> /xxx/sbox/private/trunk2.image/i686-32/bin/x-tools/libexec/gcc/i686-unknown=
> =3D
> -linux-gnu/4.5.2
> lto-plugin.lo -Lno/lib -lelf ../libiberty/pi
> c/libiberty.a
> [ALL=C2=A0 ]=C2=A0 =C2=A0 configure: creating cache ./config.cache
> [ALL=C2=A0 ]=C2=A0 =C2=A0 checking for --enable-version-specific-runtime-li=
> bs... no
> [ALL=C2=A0 ]=C2=A0 =C2=A0 checking for a BSD-compatible install...
> /home/xxx/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/tools/bin=
> =3D
> /install
> -c
> [ALL=C2=A0 ]=C2=A0 =C2=A0 checking for gawk... gawk
> [ALL=C2=A0 ]=C2=A0 =C2=A0 checking build system type... x86_64-build_unknow=
> n-linux-gnu
> [ALL=C2=A0 ]=C2=A0 =C2=A0 checking host system type... ./libtool: line 5195=
> : cd:
> no/lib: No such file or directory
> [ALL=C2=A0 ]=C2=A0 =C2=A0 libtool: link: cannot determine absolute director=
> y name of `no/l=3D
> ib'
> [ERROR]=C2=A0 =C2=A0 make[3]: *** [liblto_plugin.la] Error 1
> [ALL=C2=A0 ]=C2=A0 =C2=A0 make[3]: Leaving directory
> `/home/xxx/sbox/private/trunk2.image/i686-32/bin/cross-tool/.build/i686-unk=
> =3D
> nown-linux-gnu/build/bu
> ild-cc/lto-plugin'
> [ERROR]=C2=A0 =C2=A0 make[2]: *** [all-lto-plugin] Error 2
>
>
> I spent the whole afternoon Googling but found nothing that could help.
>
> Any suggestion? I am not even sure I understand the error. There is no
> no/lib directory on the machine where the build complete successfully.
>
> Thanks in advance
>
> --
> For unsubscribe information see http://sourceware.org/lists.html#faq
>

Your message has some weird escaping in it. Can you post your
build.log somewhere and link it here?

-Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list