[PATCH rebase] binutils: Fix elf2flt compile on more modern systems

Bryan Hundven bryanhundven@gmail.com
Fri Dec 5 21:10:00 GMT 2014


Solomon,

On Fri, Dec 5, 2014 at 6:23 AM, Solomon Peachy <pizza@shaftnet.org> wrote:
> Without this fix, elf2flt will blow up complaining that it can't resolve
> dlopen() and friends.  One has to explicitly pass '-ldl' on the final
> linking command line, because the system linker is not resolving
> indirect dependent shared libraries.
>
> I've needed to this patch for several years on Fedora systems.
>
> Signed-off-by: Solomon Peachy <pizza@shaftnet.org>
> ---
>  scripts/build/binutils/binutils.sh | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/scripts/build/binutils/binutils.sh b/scripts/build/binutils/binutils.sh
> index b6207be..c935f8d 100644
> --- a/scripts/build/binutils/binutils.sh
> +++ b/scripts/build/binutils/binutils.sh
> @@ -291,6 +291,7 @@ do_elf2flt_backend() {
>      CT_DoExecLog CFG                                            \
>      CFLAGS="${cflags}"                                          \
>      LDFLAGS="${ldflags}"                                        \
> +    LIBS="-ldl"                                                 \
>      "${CT_SRC_DIR}/elf2flt-${CT_ELF2FLT_VERSION}/configure"     \
>          --build=${CT_BUILD}                                     \
>          --host=${host}                                          \
> --
> 1.9.3

Accepted!

Thanks,

-Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list