build fails at installing C library

arnaud gaboury arnaud.gaboury@gmail.com
Tue Apr 15 16:43:00 GMT 2014


On Mon, Apr 14, 2014 at 3:21 PM, arnaud gaboury
<arnaud.gaboury@gmail.com> wrote:
> Dear all,
>
> my host : Arch linux X86_64 fully upgarded
> Linux3.14
> GCC 4.8.2-8
> glibc 2.19-3
>
> Build target : arm-cortex_a8
> My path includes /usr/share.
>
> From my .config file:
>
> CT_LIBC="eglibc"
> CT_LIBC_VERSION="2_18"
> CT_LIBC_eglibc=y
> # CT_LIBC_uClibc is not set
> # CT_LIBC_glibc is not set
> CT_LIBC_none_AVAILABLE=y
> CT_LIBC_mingw_AVAILABLE=y
> CT_LIBC_eglibc_AVAILABLE=y
> CT_LIBC_EGLIBC_V_2_18=y
> CT_LIBC_EGLIBC_2_16_or_later=y
> CT_EGLIBC_REVISION="HEAD"
> CT_LIBC_newlib_AVAILABLE=y
> CT_LIBC_uClibc_AVAILABLE=y
> CT_LIBC_glibc_AVAILABLE=y
>
>
> The build fails:
> [ERROR]  >>  Build failed in step 'Installing C library headers & start files'
>
> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@257]
> [ERROR]  >>        called from:
> do_libc_backend_once[scripts/build/libc/glibc-eglibc.sh-common@347]
> [ERROR]  >>        called from:
> do_libc_backend[scripts/build/libc/glibc-eglibc.sh-common@143]
> [ERROR]  >>        called from:
> do_libc_start_files[scripts/build/libc/glibc-eglibc.sh-common@60]
> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@638]
>
>
> from build log :
>
> [CFG  ]    checking version of arm-cortex_a8-linux-gnueabi-gcc    ... 4.8.3, ok
> [CFG  ]    checking for gnumake... no
> [CFG  ]    checking for gmake... no
> [CFG  ]    checking for make... make
> [CFG  ]    checking version of make... 4.0, bad
> [CFG  ]    checking for gnumsgfmt... no
> [CFG  ]    checking for gmsgfmt... no
> [CFG  ]    checking for msgfmt... msgfmt
> [CFG  ]    checking version of msgfmt... 0.18.3, ok
> [CFG  ]    checking for makeinfo... makeinfo
> [CFG  ]    checking version of makeinfo... 5.2, ok
> [CFG  ]    checking for sed... sed
> [CFG  ]    checking version of sed... 4.2.2, ok
> [CFG  ]    checking for gawk... gawk
> [CFG  ]    checking version of gawk... 4.1.0, ok
> [CFG  ]    checking for arm-cortex_a8-linux-gnueabi-nm...
> arm-cortex_a8-linux-gnueabi-nm
> [CFG  ]    checking for autoconf... autoconf
> [CFG  ]    checking whether autoconf works... no
> [ERROR]    configure: error:
> [CFG  ]    *** These critical programs are missing or too old: make
>

Issue was solved this way :

# C-library
#
CT_LIBC="eglibc"
CT_LIBC_VERSION="2_19"
CT_LIBC_eglibc=y
# CT_LIBC_uClibc is not set
# CT_LIBC_glibc is not set
CT_LIBC_none_AVAILABLE=y
CT_LIBC_mingw_AVAILABLE=y
CT_LIBC_eglibc_AVAILABLE=y
CT_LIBC_EGLIBC_V_2_19=y

Now, for the record :

* ct-ng build fine with Linaro 4.8.3-201403
* ct-ng build fine with gnu GCC 4.9

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list