Segmentation fault

Michael Powell mwpowellhtx@gmail.com
Wed Mar 6 18:13:00 GMT 2013


Well...

On Tue, Mar 5, 2013 at 7:53 PM, Bill Pringlemeir <bpringle@sympatico.ca> wrote:
> On  5 Mar 2013, mwpowellhtx@gmail.com wrote:
>
>> I have a simple Hello World type app, that's all it does, cout <<
>> "Hello, World!" << endl and that's it. That one works when I cross
>> compile and run it on the target.
>
>> Then I work int some more elaborate functionality involving I2C
>> features, and I get segmentation fault.
>
> Have you updated the libraries on the target?  See '*-populate' in your
> Crosstool directory.  Also check the proper libraries are present with
> 'ldd'; there can be a version in ct-ng.  Then it is possible it is your
> code.

I ran ldd on the x86 build, and I get not a dynamic executable. So I
guess meaning there are no shared libraries of any sort. Okay.

Then I run <cross/>-ldd --root / <app/>, and it doesn't return
anything to me. But I doubt it would because I'm not linking any known
libraries to it dynamically.

Sorry it's been several years since dealing with C/C++, linkage
dependencies, etc, much less cross compilation issues.

Not sure about what libraries are there on the target. Probably I was
linking against a different version kernel? GLIBC? Or something like
that?

I have updated my cross compiler to target kernel 3.7.1 instead of
3.7.3 (?) in the meantime.

> hth,
> Bill Pringlemeir.
>
>
> --
> For unsubscribe information see http://sourceware.org/lists.html#faq
>

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list