arm-none-eabi-gdb fails bacause xml is disabled

Ormund Williams ormundw@panix.com
Sun Mar 3 14:52:00 GMT 2013


On Sun, 2013-03-03 at 07:28 -0500, Trevor Woerner wrote:
> Hi Ormund,
> 
> On Sun, Mar 3, 2013 at 2:29 AM, Ormund Williams <ormundw@panix.com> wrote:
> > I've been trying to build a tool chain for the STM32F0 an ARM Cortex M0
> > mocrocontorller.  I have the STM32F0-Discovery board and have been able
> > to download the resulting binaries using open-ocd.
> 
> Awesome! What a coincidence! I just started working with an STM32F4
> Discovery board :-)
> 
> If you don't mind, I would be interested in getting more details about
> using open-ocd from you (which would be off-topic for this list). I'm
> using the st-util through gdb and that's working for me so far.
> 
I've added you to my white-list so I'll see your emails.  I'll send you
what I have on open-ocd.

> > The programs work
> > but when I try to load them using GDB I get this error:
> >
> > warning: Can not parse XML memory map; XML support was disabled at
> > compile time
> >
> > I'm running on Debian-testing and have both libexpat1-dev and
> > libxml2-dev packages loaded, is there something else I need?
> 
> 
> There are two things you can try:
> 
> 1) under "Debug Facilities" -> "gdb" you can provide the following
> string for "Cross-gdb extra config":
> --enable-expat --with-expat=yes
> 
> 2) apply the patch I sent to the mailing list yesterday (subject line:
> "[PATCH] debug/gdb: include expat for gdb-cross") and rebuild
> 
> From what I could determine, ct-ng specifically disables expat (an
> XML-processing library) unless you are building a native gdb, and you
> can only build a native gdb if you aren't using "bare-metal". This
> isn't true in our case, so by default ct-ng forces expat to be
> disabled.
> 
I tried applying you patch to crosstool-ng-1.18.0 and the it all
works!!! 

> 
> Just out of curiosity, which base configuration did you use (I used
> arm-unknown-eabi). If this is the same one you used, were you able to
> keep C++ enabled under "C compiler" without build issues?
> 
Same here, then I turned off use-mmu and it failed to build.  I then
turned on experimental and tried later versions of everything until I
got a working combo; it would build AND compile the code.

Now everything works.  Thanks Trevor!!


Regards

-- 
Ormund


--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list