Build Failure for PowerPC using crosstool-ng 1.9.3

Yann E. MORIN yann.morin.1998@free.fr
Fri Mar 9 08:45:00 GMT 2012


Dominique, All,

Please, wrap lines at <80 chars, it's easier to read.

On Friday 09 March 2012 01:40:35 Van Rafelghem Dominique wrote:
> I have a PowerPC platform that is running an older Linux kernel
> 2.4.18 for which I downloaded the tar.gz file.

The 2.4 series of Linux is not supported by crosstool-NG. It's a too old
version. Only starting around 2.6.18 (dpeending on the target architecture)
was Linux capable of exporting its headers.

My first suggestion would be to update your target kernel. 2.4.18 is really
old, by nowadays standards: it was released more than 10 years ago!

If you really can't update, then you *might* be able to get a toolchain for
your system anyway. Just select the oldest kernel available in crosstool-NG
and tell glibc that it should support back to linux-2.4.18:

    C-library  --->
      Minimum supported kernel version (Specific kernel version)  --->
        Specific kernel version
          (2.4.18) Minimum kernel version to support

But you may encounter some rough edges...

Also, crosstool-NG 1.9.3 is old, no longer maintained, and no longer
supported. Latest is 1.14.1. Please upgrade.

Regards,
Yann E. MORIN.

-- 
.-----------------.--------------------.------------------.--------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
| +33 223 225 172 `------------.-------:  X  AGAINST      |  \e/  There is no  |
| http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
'------------------------------^-------^------------------^--------------------'

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list