mips64el-unknown-linux-gnu-ld: ABI is incompatible with that of the selected emulation

陳韋任 (Wei-Ren Chen) chenwj@iis.sinica.edu.tw
Sat Jul 21 20:43:00 GMT 2012


Hi all,

  I am trying to build a mips64 cross compiler which support multilib,
but I have a problem with building stage 2 gcc. Here is the error
message,

  /local/chenwj/install//bin/mips64el-unknown-linux-gnu-ld:
  /local/chenwj/install//mips64el-unknown-linux-gnu/sys-root/usr/lib/../lib/libc.a(dl-version.o):
  ABI is incompatible with that of the selected emulation
  /local/chenwj/install//bin/mips64el-unknown-linux-gnu-ld: failed to
  merge target specific data of file
  /local/chenwj/install//mips64el-unknown-linux-gnu/sys-root/usr/lib/../lib/libc.a(dl-version.o)


Any idea on what I am doing wrong? You can clone the script I am using
from https://code.google.com/p/mips-script/ .

  Thanks!

Regards,
chenwj

-- 
Wei-Ren Chen (陳韋任)
Computer Systems Lab, Institute of Information Science,
Academia Sinica, Taiwan (R.O.C.)
Tel:886-2-2788-3799 #1667
Homepage: http://people.cs.nctu.edu.tw/~chenwj

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list