How do you find a configuration that builds?

Grant Edwards grant.b.edwards@gmail.com
Wed Aug 15 02:47:00 GMT 2012


I'm trying to update from 1.12 to 1.16, and so far it's been a
failure.  With 1.12, I just picked versions for gcc, binutils, uclibc,
and gdb -- then things just built.  With 1.16, almost all the
combinations I've tried fail.  

I even tried using the same versions that worked with 1.12, and that
fails (errors building uClibc because of invalid .size directives for
_init and _fini).  And that's using the same versions of gcc,
binutils, and uClibc that I was using with 1.12.

How does one find a combination of versions that builds?  Is it just
days of trail and error until you stumble across a usable combination
of recent versions?

Or is there something I'm missing?

My builos always seem to fail building uClibc (invalid .size directive
for _init _fini), or building the final compiler's libgcc (missing
pthread.h file).

The .size directive thing seems to be solved by dropping back from
binutils 0.21 to to binutils 0.20, even though 0.21 worked using ct-ng
1.12.

I haven't figured out what's causing the "missing pthread.h" error:
all uClibc versions/configurations I've tried newer than 0.9.30 seem
to have that problem.

Is anybody else able to build recent uClibc versions?  With what versions
of gcc and/or binutils?


(ARM target, FWIW)


--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list