Disable gdb Python support?

Grant Edwards grant.b.edwards@gmail.com
Tue Aug 14 20:52:00 GMT 2012


We've been using crosstool-ng for a couple years -- we're currently
using 1.12.  Gdb used to work find for us, but it seems to have broken
when we switched our configuration from 6.8 to 7.2. It appears that
newer versions of gdb are being built with some sort of Python
dependency:

ldd ./arm-linux-gdb
        linux-gate.so.1 (0xffffe000)
        libncurses.so.5 => /lib/libncurses.so.5 (0xb7743000)
        libz.so.1 => /lib/libz.so.1 (0xb772e000)
        libm.so.6 => /lib/libm.so.6 (0xb7707000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb76ee000)
        libdl.so.2 => /lib/libdl.so.2 (0xb76e9000)
        libutil.so.1 => /lib/libutil.so.1 (0xb76e5000)
>>>>    libpython2.6.so.1.0 => /usr/lib/libpython2.6.so.1.0 (0xb758a000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb7560000)
        libc.so.6 => /lib/libc.so.6 (0xb7410000)

That's causing problems for us since not all of our host machines have
the same python versions installed.

We didn't seem to have this problem with gdb 6.8.

Is there any way to disable the Python support when crosstool-ng
builds the host-side gdb?

-- 
Grant Edwards               grant.b.edwards        Yow! When this load is
                                  at               DONE I think I'll wash it
                              gmail.com            AGAIN ...


--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list