Build ppl-0.10.2 fails on cygwin host

Leopold M. Kogler leopold.m.kogler@gmail.com
Sun Aug 12 09:33:00 GMT 2012


Hi

I tried to install crosstool-ng-1.16, 1.15 , and 1.15.2 on a win vista 
64 bit cygwin host without success.
The highest version that works for me is 1.13.2 , but there i can't 
install ppl-0.10.2.(same as in version 1.9.1 and 1.10.0 which I also tried)
It stops with the following error:

[INFO ]  Installing PPL
[EXTRA]    Configuring PPL
[EXTRA]    Building PPL
[ERROR] 
/home/leokog/build_toolchain-1.10.0/targets/src/ppl-0.10.2/src/checked.inlines.hh:607: 
internal compiler error: in invert_truthvalue, at fold-const.c:2719
[ERROR]    make[4]: *** [Box.lo] Error 1
[ERROR]    make[3]: *** [all] Error 2
[ERROR]    make[2]: *** [all-recursive] Error 1
[ERROR]    make[1]: *** [all] Error 2
[ERROR]    Build failed in step 'Installing PPL'
[ERROR]    Error happened in 
'/usr/local/lib/ct-ng-1.10.0/scripts/functions' in function 
'CT_DoExecLog' (line unknown, sorry)
[ERROR]          called from 
'/usr/local/lib/ct-ng-1.10.0/scripts/build/companion_libs/ppl.sh' at 
line # 62 in function 'do_ppl'
[ERROR]          called from 
'/usr/local/lib/ct-ng-1.10.0/scripts/crosstool-NG.sh' at line # 606 in 
function 'main'
[ERROR]    Look at 
'/home/leokog/x-tools/x86_64-unknown-linux-gnu/build.log' for more info 
on this error.
[ERROR]  (elapsed: 93:13.50)
[93:18] / /usr/local/bin/ct-ng:143: recipe for target `build' failed
make: *** [build] Error 2

sorry for using this old version but the new ones won't work.
Please help, my compiling skills are low.

Thanks for every help




--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list