[PATCH] fix problem with "install" call in populate script

Anthony Foiani anthony.foiani@gmail.com
Fri Apr 27 02:08:00 GMT 2012


Greetings all --

Due to the usual cascade of requirements and bugs, I had to upgrade my
toolchain to gcc-4.6.3, so I updated my ct-ng to latest hg head.  (I
tried the 1.14.1 release, but that didn't have the 4.6.3 stuff in it).

When I ran though my old scripts for building my ramdisk, I got new errors:

/opt/cross/platforms/foo/xtools/bin/powerpc-e300c3-linux-gnu-populate:
line 208: /usr/bin/install -c: No such file or directory
readelf: Error: 'lib/libpthread.so.0': No such file

Adding verbosity didn't help.  It turns out that autoconf found
"/usr/bin/install -c" to be the correct install tool.  When populate
tries to call it, however, it keeps it in double-quotes, and the shell
tries to interpret the whole string as a command name:

  # this is the value returned by autoconf and stored in CT_install
  $ ins="/usr/bin/install -c"

  # if we call it with quotes, the command is not found
  $ "${ins}"
  bash: /usr/bin/install -c: No such file or directory

  # removing the quotes lets it work as expected
  $ ${ins}
  /usr/bin/install: missing file operand
  Try `/usr/bin/install --help' for more information.

The fix is easy: just remove the quotes around the use of ${install}.

Patch attached.

Thanks,
t.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ctng-fix_populate_install.patch
Type: application/octet-stream
Size: 1507 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/crossgcc/attachments/20120427/b5931e47/attachment.obj>
-------------- next part --------------
--
For unsubscribe information see http://sourceware.org/lists.html#faq


More information about the crossgcc mailing list