MaverickCrunch patches

Yann E. MORIN yann.morin.1998@anciens.enib.fr
Sun Sep 11 14:02:00 GMT 2011


Martin, All,

On Sunday 11 September 2011 02:58:06 Martin Guy wrote:
>   Is it worth including the patches to fix GCC code generation for the
> Cirrus Logic MaverickCrunch FPU found in their EP93xx series SoCs?

Yes, I'm pretty much interested in them!

>   There are patches for gcc-4.2.4, 4.3.3 and 4.3.4
>   (I know, I should update them to GCC-4.5, which produces smaller,
> faster code)

Well, at least let's include what is available. If you manage to later
update the MaverickCrunch patchset up to 4.5 (4.6!), we can then add it.

>   How would Crunch-hungry folks find out that they need so select
> specific versions version of GCC to get working FPU support?

First, we have to properly finish the hard/soft/softfp stuff, as it might
have some implications on Crunch (but I don't really know...). Most notably,
if hardware floating point is used, then ARM can offer an option for each
of the available FPUs: vfp{,v2,v3}, neon, crunch...

Second, in the help entry for each FPU, we can list the requirements; for
example:
 - crunch requires: gcc in [4.2.4, 4.3.3, 4.3.4]
 - neon requires gcc >= 4.5
 - and so on...

Third, we can provide a sample with crunch enabled, so people can start
off with that.

Regards,
Yann E. MORIN.

-- 
.-----------------.--------------------.------------------.--------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
| +33 223 225 172 `------------.-------:  X  AGAINST      |  \e/  There is no  |
| http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
'------------------------------^-------^------------------^--------------------'

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list