CLOOG/ppl failure in ct-ng 1.9.0

eastyhasta eastyhasta@hotmail.fr
Wed Jan 12 22:01:00 GMT 2011




Bryan Hundven-3 wrote:
> 
> On Wed, Jan 12, 2011 at 2:14 AM, Bryan Hundven <bryanhundven@gmail.com>
> wrote:
>> On Wed, Jan 12, 2011 at 12:40 AM, eastyhasta <eastyhasta@hotmail.fr>
>> wrote:
>>>
>>>
>>>
>>> Xianghua Xiao-2 wrote:
>>>>
>>>> On Fri, Nov 5, 2010 at 8:34 AM, Bob Dunlop <bob.dunlop@xyzzy.org.uk>
>>>> wrote:
>>>>> On Thu, Nov 04 at 02:41, Xianghua Xiao wrote:
>>>>> ...
>>>>>> [ERROR]    Build failed in step 'Installing CLooG/ppl'
>>>>> ...
>>>>>> This is on Ubuntu 10.04.
>>>>>>
>>>>>> Anyone saw this?
>>>>>
>>>>> Yep, seen it on Gentoo as well.
>>>>>
>>>>> I just downgraded the build to CLooG 0.15.9 and all was fine so I
>>>>> guess
>>>>> the problem is actually with CLooG 0.15.10 rather than ct-ng 1.9.0.
>>>>>
>>>>> --
>>>>>        Bob Dunlop
>>>>>
>>>>
>>>> This is correct, last night I switched ot CLooG 0.15.9 and it finished
>>>> without errors this morning.
>>>>
>>>> Cheers,
>>>>
>>>> Xianghua
>>>>
>>>>
>>>
>>> Hello everyone
>>> I have the same issue with crosstool-ng-1.9.1 and crosstool-ng-1.9.2.
>>> I am new on programming on Linux and I don't understand your solution.
>>> Can you explain it?
>>> How to downgrade the build to ClooG 0.15.9??
>>
>> There are a few patches floating around, but I'm not sure that path
>> leads to the right solution.
>>
>> http://repo.or.cz/w/cloog-ppl.git -- the cloog-ppl repository
>> (originally a port of cloog to the parma polyhedra library) hasn't had
>> an update since late August of 2010. But PPL is still very busy...
>>
>> http://repo.or.cz/w/cloog.git -- which was the original cloog tree has
>> released 0.16.1 4 days ago, and PolyLib
>> (http://icps.u-strasbg.fr/polylib/) has been gpl3 since January of
>> 2010.
>>
>> http://gcc.gnu.org/wiki/Graphite/Merge_CLooG_PPL_back_to_CLooG
>>
>> I wonder if newer toolchains should use Cloog+PolyLib_or_PPL instead
>> of Cloog-PPL+PPL, and if it is tested? If this is true, then please
>> remove 0.15.10.
> 
> I misspoke. It would be: ClooG+PPL instead of ClooG-PPL+PPL
> 
>> To use 0.15.9, in `ct-ng menuconfig` navigate to:
>>    Companion Libraries  --->
>>    CLooG/ppl version (0.15.10)  --->
>>    and select 0.15.9
>>
>> Or...
>>
>> Edit your .config file and set
>>    CT_CLOOG_V_0_15_10=y
>> to
>>    # CT_CLOOG_V_0_15_10 is not set
>>
>> ...and set
>>    # CT_CLOOG_V_0_15_9 is not set
>> to
>>    CT_CLOOG_V_0_15_9=y
>>
>> ...and set
>>    CT_CLOOG_VERSION to 0.15.9
>>
>> I prefer the ct-ng menuconfig way, personally. ;-)
>>
>>> Thanks
>>> Eastyhasta
>>>
>>> --
>>> View this message in context:
>>> http://old.nabble.com/CLOOG-ppl-failure-in-ct-ng-1.9.0-tp30135491p30651275.html
>>> Sent from the Sourceware - crossgcc list mailing list archive at
>>> Nabble.com.
>>>
>>>
>>> --
>>> For unsubscribe information see http://sourceware.org/lists.html#faq
>>>
>>>
>>
>>
>> -Bryan
>>
> 


Thank you very much for your quick answer. With your help I succeed to
downgrade the build to ClooG 0.15.9.

In fact it was not my single problem. 
I also followed the message of Ilya A. Volynets-Evenbakh see above.
I added this line; "./autogen.sh"  in file
"scripts/build/companion_libs/cloog.sh" 

     CT_Pushd "${CT_SRC_DIR}/cloog-ppl${_t}"
     CT_Patch nochdir "cloog-ppl" "${CT_CLOOG_VERSION}"
+    ./autogen.sh
     CT_Popd

Now it's working. Thanks
Eastyhasta
-- 
View this message in context: http://old.nabble.com/CLOOG-ppl-failure-in-ct-ng-1.9.0-tp30135491p30654810.html
Sent from the Sourceware - crossgcc list mailing list archive at Nabble.com.


--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list