ct-ng: uClibc build fails: missing libgcc_eh.a for me as well

Tor Krill tor@codeknot.com
Tue Aug 30 15:54:00 GMT 2011


Hi,

I'm trying to build gcc 4.4.6, uclibc 0.9.32 linux-2.6.29.4 or
linux-2.6.39.4 for a arm based board (Atmel at91).

I have tried both on a 64 and 32 bit ubuntu 10.10 and i used ct-ng
1.12.1

As Grant Edwards
(http://sourceware.org/ml/crossgcc/2011-08/msg00024.html) i get:

[ALL  ]      STRIP -X --strip-debug -R .note -R .comment lib/libpthread.a
[ALL  ]      LD ld-uClibc-0.9.32.1-git.so
[ALL  ]    arm-unknown-linux-uclibcgnueabi-gcc: libgcc_eh.a: No such file or directory
[ERROR]    make[1]: *** [lib/ld-uClibc.so] Error 1
[ALL  ]    make[1]: *** Waiting for unfinished jobs....
[ALL  ]      STRIP -x -R .note -R .comment lib/libc.a
[ALL  ]    make[1]: Leaving directory `/home/tor/build/toolchain/.build/arm-unknown-linux-uclibcgnueabi/build/build-libc'
[ERROR]    
[ERROR]    >>  Build failed in step 'Installing C library'
[ERROR]    >>
[ERROR]    >>  Error happened in: CT_DoExecLog[scripts/functions]
[ERROR]    >>        called from: do_libc[scripts/build/libc/uClibc.sh@196]
[ERROR]    >>        called from: main[scripts/crosstool-NG.sh@588]
[ERROR]    >>
[ERROR]    >>  For more info on this error, look at the file: 'build.log'
[ERROR]    >>  There is a list of known issues, some with workarounds, in:
[ERROR]    >>      '/usr/local/share/doc/ct-ng-1.12.1/B - Known issues.txt'
[ERROR]    
[ERROR]    Build failed in step 'Installing C library'
[ERROR]    
[ERROR]    (elapsed: 9:54.92)

(Backing down to uClibc 0.9.30.3 seems to work.)

Am I doing something wrong or is this a bug?

Best Regards,

/Tor



--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list