crosstool-ng on Mac OS X 10.6.2 (Snow Leopard) and issue with mpfr

Thu Feb 11 19:33:00 GMT 2010

Uwe, All,

On Sunday 07 February 2010 11:18:36 Uwe Papengut wrote:
> thanks for the quick help. In past if I build ct-ng I got the uname-warning

Yes, I spotted a left-over that still uses uname -o without failing back to
using uname -s. Will fix.

> My new problem is with build-command is "mpfr":
> mac-mini:ct-ng uwepapengut$ ct-ng -d build

This will debug the ct-ng frontend. If you want to _actually_see_ what
is going on, you will have to have a look at the build.log file that is
present in the toolchain installation directory.

> [INFO ]  =================================================================
> [INFO ]  Retrieving needed toolchain components' tarballs
> [ERROR]    Could not retrieve 'mpfr-2.4.1'.

OK. Seems pretty obvious: crosstool-NG is mnot able to download mpfr-2.4.1.
Did you check that the MPFR site is up and reachable from your place?
The MPFR site is down from time to time, and there is nothing we can do
about it (except I did set up a small mirror on my site. look at the
help for the mirror options for the actual location).

> I run the "build-mpfr-on-darwin.patch" succesfully and I used mpfr-2.4.2
> and mpfr-2.4.1 and got the same error. 

That patch is already upstream. If you want to benefit from the patches
Titus sent earlier, and that I have already partly applied, you should
use a clone of the <Mercurial repository.

Yann E. MORIN.

|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
| +33 223 225 172 `------------.-------:  X  AGAINST      |  \e/  There is no  |
| | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |

For unsubscribe information see

More information about the crossgcc mailing list