Building toolchain with crosstool-ng V1.9.0 on Mac OS X 10.6.5

Uwe Papengut uwe.papengut@t-online.de
Fri Dec 3 19:01:00 GMT 2010


Am 01.12.2010 um 18:46 schrieb Uwe Papengut:

> 
>> Hi,
>> 
>> On Mon, Nov 29, 2010 at 11:58 AM, Uwe Papengut <uwe.papengut@t-online.de> wrote:
>>> Hello,
>>> 
>>> with crosstool-ng V1.6.0 on Mac OS X 10.6.2 I build succesfully a toolchain for ARM.
>>> 
>>> I tested the same with crosstool-ng V1.9.0 on Mac OS X 10.6.5 and my old config-file. I got many errors.
>>> At the old version I had to use some patches. Is there anything else at the new version?
>>> 
>> Can you precise which errors you are getting ? that would help answering.
>> 
>> Thanks,
>> - Arnaud
> 
> 
> 
> Hi, 
> 
> here are my errors:
> 
> 
> ....
> [INFO ]  =================================================================
> [INFO ]  Installing binutils
> [EXTRA]    Configuring binutils
> [EXTRA]    Building binutils
> [EXTRA]    Installing binutils
> [INFO ]  Installing binutils: done in 147.00s (at 07:21)
> [INFO ]  =================================================================
> [INFO ]  Installing static core C compiler
> [EXTRA]    Configuring static core C compiler
> [ERROR]    configure: error: Building GCC requires GMP 4.1+ and MPFR 2.3.0+.
> [ERROR]    Build failed in step 'Installing static core C compiler'
> [ERROR]    Error happened in '/volumes/ct/ctng/lib/ct-ng-1.9.0/scripts/functions' in function 'CT_DoExecLog' (line unknown, sorry)
> [ERROR]          called from '/volumes/ct/ctng/lib/ct-ng-1.9.0/scripts/build/cc/gcc.sh' at line # 203 in function 'do_cc_core'
> [ERROR]          called from '/volumes/ct/ctng/lib/ct-ng-1.9.0/scripts/build/cc/gcc.sh' at line # 52 in function 'do_cc_core_pass_1'
> [ERROR]          called from '/volumes/ct/ctng/lib/ct-ng-1.9.0/scripts/crosstool-NG.sh' at line # 597 in function 'main'
> [ERROR]    Look at '/volumes/ct/crosstool/build.log' for more info on this error.
> [ERROR]  (elapsed: 7:24.00)
> [07:24] / make: *** [build] Error 1
> 
> 
> Best Regards,
> Uwe
> 

Hello,

my first error is: 

[ERROR]    configure: error: Building GCC requires GMP 4.1+ and MPFR 2.3.0+.

In my config file I used:

#
# Companion libraries
#
CT_WRAPPER_NEEDED=y
CT_GMP_MPFR=y
CT_GMP_V_4_3_1=y
# CT_GMP_V_4_3_0 is not set
# CT_GMP_V_4_2_4 is not set
# CT_GMP_V_4_2_2 is not set
CT_GMP_VERSION="4.3.1"
# CT_MPFR_V_2_4_2 is not set
CT_MPFR_V_2_4_1=y
# CT_MPFR_V_2_4_0 is not set
# CT_MPFR_V_2_3_2 is not set
# CT_MPFR_V_2_3_1 is not set
CT_MPFR_VERSION="2.4.1"
# CT_PPL_CLOOG_MPC is not set

GMP was greater than 4.1 and MPFR was greater then 2.3.0. 

Can anyone help me to find the error?

Regards,
Uwe



--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list