problem with ct-ng 1.5.1: "fragment: command not found"

Matthias Kaehlcke matthias@kaehlcke.net
Fri Oct 30 11:30:00 GMT 2009


hi yann,

El Fri, Oct 30, 2009 at 09:50:03AM +0100 Yann E. MORIN ha dit:

> On Thursday 29 October 2009 21:24:42 Matthias Kaehlcke wrote:
> > the build of a uclibc toolchain for i686 using crosstool-ng v1.5.1
> > fails with the following error:
> > [ALL  ]
> > /usr/local/src/ct-ng-build/targets/src/binutils-2.18/ld/emultempl/elf32.em:
> > line 11: fragment: command not found 
> > ... (more lines with the same error)
> > anyone ran into this issue and knows how to solve it?
> 
> Set "Paths and misc options" -> "Shell to use as CONFIG_SHELL" -> bash
> 
> This fixed it for me, binutils 2.18 seems to be sensible to such stuff.
> (In my case /bin/sh pointed to bash, but it was still failing if I did
>  not explicitly set CONFIG_SHELL to bash).

thanks for your reply

CONFIG_SHELL was already set to bash :(

any other ideas?

-- 
Matthias Kaehlcke
Embedded Linux Engineer
Barcelona

          We can't solve problems by using the same kind
             of thinking we used when we created them
                         (Albert Einstein)
                                                                 .''`.
    using free software / Debian GNU/Linux | http://debian.org  : :'  :
                                                                `. `'`
gpg --keyserver pgp.mit.edu --recv-keys 47D8E5D4                  `-

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list