ct-ng 1.4.2: problem in creating x86_64 toolchain

Zvi Vered veredz72@gmail.com
Fri Oct 30 04:20:00 GMT 2009


I used ct-ng-1.4.2 to build a toolchain for x86-64.
The steps I did:
1. ct-ng x86_64-unknown-linux-gnu
2. Remove java
3. ct-ng build

The toolchain was build OK. When I ran "x86_64-unknown-linux-gnu --v" I got:

Using built-in specs.
Target: x86_64-unknown-linux-gnu
Configured with:
--build=i386-build_redhat-linux-gnu --host=i386-build_redhat-linux-gnu
--enable-languages=c,c++ --disable-multilib
--with-pkgversion=crosstool-NG-1.4.2 --enable-__cxa_atexit
--disable-nls --enable-threads=posix --enable-symvers=gnu --enable-c99
--enable-long-long --enable-target-optspace
Thread model: posix
gcc version 4.3.2 (crosstool-NG-1.4.2)

But when I tried: ldd ld-2.9.so
I got: not a dynamic executable

I also tried ldd myapp.out which is a very simple executable I created
and got the same response.

I built a vanilla kernel with this toolchain. But when this kernel
searches for init, it can't find one. When I replaced the init with
one created with an i686 toolchain it worked fine.

Then I looked at build.log and saw some errors starting from line 25150 :
[ALL  ]    objdump: init-first.o: File format not recognized

What is the reason for those errors ?

By the way, ct-ng is a great tool !!!.
I built a toolchain for i686 and it works great.

Zvika Vered
-------------- next part --------------
A non-text attachment was scrubbed...
Name: .config
Type: application/octet-stream
Size: 7273 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/crossgcc/attachments/20091030/626592e4/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: build.log.bz2
Type: application/x-bzip2
Size: 414059 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/crossgcc/attachments/20091030/626592e4/attachment.bz2>
-------------- next part --------------
For unsubscribe information see http://sourceware.org/lists.html#faq

More information about the crossgcc mailing list