ARM with old kernel

Andy Johnson
Tue Jan 27 19:04:00 GMT 2009


> The problem seems to be solved by the attached patch , as I had faced
> similar problem earlier. Please try it and let me know if it works for
> Regards
> Partha Acharya

Is this for the configure file in the glibc source root?  Which version
of glibc is this for?  At what point did you apply this patch, before
the build starts, or do you need to have it stop so you can apply it

Anyway, I thought I was able to solve the problem a different way.
I had also tried to use a current kernel, but set the support kernel
version option to 2.6.9 (my target system).  It would die with the error
in this link (but build OK when I didn't set the kernel version):

The patch is supposed to work for glibc 2_8, but I have only tested it
for glibc 2.7 and 2_9.  Basically it's a one line fix to add an include
for tls.h to lowlevellock.h.  It builds without errors, but when I try
to run an application built with it, I get "Hello World!" followed by
an invalid instruction error.  It's progress if one considers that at
least I get some output whereas I didn't before.  Again, I'm back to
the old "just because it builds without errors doesn't mean it ain't

Andy Johnson

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 120-ARM-THREAD_SELF.patch
Type: application/octet-stream
Size: 389 bytes
Desc: 120-ARM-THREAD_SELF.patch
URL: <>
-------------- next part --------------
For unsubscribe information see

More information about the crossgcc mailing list