[crosstool-ng] error building x86 toolchain

Matthias Kaehlcke matthias@kaehlcke.net
Wed Jan 7 07:17:00 GMT 2009


El Sat, Jan 03, 2009 at 05:49:27PM +0100 Yann E. MORIN ha dit:

> On Friday 02 January 2009 18:52:35 Matthias Kaehlcke wrote:
> > i ran into an error during the crosstool-ng build for a x86
> > toolchain in the compilation of pthread_rwlock_tryrdlock.c:
> [--SNIP--]
> > glibc	 2.7
> 
> I was unable to build any glibc-2.7 based toolchain for i[3456]86. I always
> encountered the same problem as yours, and found no solution on-line. If any
> one has a fix, speak aloud! :-)
> 
> That's why I stick to glibc-2.6.1. Also, glibc is not my favourite C library,
> and thus I did not invest too much time trying to solve this issue.
> 
> This *might* be solved with a more recent glibc, but because there is no
> tarball available, and because crosstool-NG does not (yet) support fetching
> directly from cvs/svn/git, I was able to test neither 2.8 nor 2.9.

good to know that you have the same problem. for my current purpose
a toolchain with uClibc is a good alternative, so i'll try to build
one.

-- 
Matthias Kaehlcke
Embedded Linux Engineer
Barcelona

                If you don't know where you are going,
               you will probably end up somewhere else
                         (Laurence J. Peter)
                                                                 .''`.
    using free software / Debian GNU/Linux | http://debian.org  : :'  :
                                                                `. `'`
gpg --keyserver pgp.mit.edu --recv-keys 47D8E5D4                  `-

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list