Installing GCC on a Redhat AS 2.1

Clemens Koller
Fri Oct 5 23:30:00 GMT 2007

This is off topic here since your topic has nothing to do with cross-compiling.

Carlos Narváez schrieb:
>  I'm on my second day of settiung up my Linux Server. The Flavor I
> installed is the RedHat As 2.1, I was supposed to install PostgreSQL
> 8.1 but when I tried doing so, it said that I do not have any valid C
> Compiler. I tried typing "man gcc" just to see and it appears I do not
> have any gcc on my box.

Thought about asking RedHat?
Please use their mailing lists / forums / service.

> So I downloaded one, and when I tried to configure its prefix it said:
> [root@localhost gcc-4.1.1]# ./configure --prefix="/sbin/gcc"
> loading cache ./config.cache
> checking host system type... i686-pc-linux-gnuoldld
> checking target system type... i686-pc-linux-gnuoldld
> checking build system type... i686-pc-linux-gnuoldld
> checking for a BSD compatible install... /usr/bin/install -c
> checking whether ln works... yes
> checking whether ln -s works... yes
> checking for gcc... no
> checking for cc... no
> configure: error: no acceptable cc found in $PATH
> Any help? I couldn't quite figure out why it's now looking for cc...

Well, the c compiler needs a c compiler to build itself.

Try to install the one RedHat provides for you using RedHat's
package management system.
Same is true for PostgreSQL. I don't think you need to compile
it yourself.

Clemens Koller
R&D Imaging Devices
Anagramm GmbH
Rupert-Mayer-Str. 45/1
81379 Muenchen
Phone: +49-89-741518-50
Fax: +49-89-741518-19

For unsubscribe information see

More information about the crossgcc mailing list