mips-elf with newlib

Michael N. Moran mike@mnmoran.org
Tue Oct 31 13:49:00 GMT 2006


Michael N. Moran wrote:
> Kai Ruottu wrote:
> 
>> But tools like 'bison', 'flex' etc. on the $build system could have
>> their influence....  I have attached the big-endian-hard-float
>> 'libgcc.a' I just got so you could compare yours with it, for
>> instance see what your 'ranlib' could say about it....
> 
> 
> # /tools/gnu/gcc/4.1.1/mips-elf/bin/mips-elf-ranlib libgcc.a
> /tools/gnu/gcc/4.1.1/mips-elf/bin/mips-elf-ranlib: libgcc.a: Malformed
> archive
> 
> That makes it look suspiciously like my binutils build may have
> a problem.
> 
> Indeed, I just tried your libgcc.a using the mips-elf-ranlib
> produced on my Fedora Core 2 machine with an identical configure
> script and binutils version (2.16.91.0.7), and the ranlib worked
> find (no Malformed archive).
> 
> GCC 4.1.1 is still building on that (rather slow) machine. I'll
> post the results tomorrow, but I'm guessing the results will
> be different. Hmmm.

Follow up:

The build of mips-elf GCC 4.1.1 on my Fedora Core 2 machine
completed without incident. Thus, it seems that there is an
issue with RH9 host or environment. I will look at the binutils
build on my RH9 box more closely today.

-- 
Michael N. Moran           (h) 770 516 7918
5009 Old Field Ct.         (c) 678 521 5460
Kennesaw, GA, USA 30144    http://mnmoran.org

"So often times it happens, that we live our lives in chains
  and we never even know we have the key."
The Eagles, "Already Gone"

The Beatles were wrong: 1 & 1 & 1 is 1



--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list