iwmmxt requires an AAPCS compatible ABI for proper operation

Khem Raj khem@mvista.com
Wed Jun 7 20:13:00 GMT 2006


Sean Kelley said the following on 06/05/2006 03:46 PM:
> In trying to build an ARM-iwmmxt-elf tool chain with interworking
> support, I have hit a roadblock with this error:
>
> /home/kelleys/crosstool-0.42/build/arm-iwmmxt-linux-gnu/gcc-4.0.2-glibc-2.3.5/gcc-4.0.2/gcc/crtstuff.c:1: 
>
> error: iwmmxt requires an AAPCS compatible ABI for proper operation
>
> Any thoughts?
Your problem is that you are trying to use Old ABI. IWMMXT needs to have 
new ARM EABI or IWMMXT ABI
which was an intermediate step before ARM EABI was finalised.

adding -mabi=iwmmxt might fix your problem. may be --with-abi=iwmmxt in 
gcc configure can do this for you.

You can enable EABI in your toolchain builds by
selecting proper target triplets

You can build an EABI toolchain using GCC 4.1 glibc 4.x and binutils 2.16+
if you want to use older versions you might have to apply some patches 
manually.


>
> Thanks,
>
> Sean
>
> -- 
> For unsubscribe information see http://sourceware.org/lists.html#faq
>


--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list