More ARM binutils fuckage

Daniel Jacobowitz dan@debian.org
Wed Dec 6 21:17:00 GMT 2006


Why is this suddenly crossposted?

On Wed, Dec 06, 2006 at 04:34:44AM +0100, Lennert Buytenhek wrote:
> Is this supported by mainline 2.6, or are you talking about the
> Montavista kernel that I'm not allowed to look at unless I pay
> Montavista a bazillion dollars?

I don't think MV's kernel is any different in this area, but I'm
not authoritative.

> You pass your old-ABI compiler the option -mabi=aapcs-linux, which works
> fine with my gcc 4.1 old-ABI toolchain and is exactly what mainline 2.6
> does.

I don't recommend doing this.  The two compilers (...gnu-gcc
-mabi=aapcs-linux and ...gnueabi-gcc) do not have exactly the same
configuration; I don't know for sure what might be different between
them, but I do know we only expect EABI compliance from the EABI
compilers.  -mabi=aapcs-linux versus -mabi=aapcs was mainly for
interoperation between arm-none-eabi-gcc and
arm-none-linux-gnueabi-gcc.

-- 
Daniel Jacobowitz
CodeSourcery

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list