More ARM binutils fuckage

Lennert Buytenhek buytenh@wantstofly.org
Wed Dec 6 01:08:00 GMT 2006


On Wed, Dec 06, 2006 at 12:22:26AM +0000, Russell King wrote:

> Enabling EABI needs a compiler which supports EABI.  That's where I
> get fuzzy but recent gcc 4 should be suitable.  I have had it suggested
> to me that EABI support in the toolchain isn't all that stable at the
> moment.

I use a bog-standard gcc 4.1.0 to cross-compile all my ARM kernels
with, which allows me to build both old-ABI and EABI kernels.  (These
days I build all kernels in EABI mode with old-ABI compat.)  I have
not run into any code generation issues with this compiler yet.

On the ARM I am running an EABI userland with glibc 2.5, and build
stuff natively with vanilla binutils 2.17.50.0.5 (2.17.5.0.3 is 'too
old', as it doesn't understand the two argument form of the .movsp
directive which one of the gcc ICE fix patches emits), and gcc 4.1.1
with some patches from gcc bugzilla to fix an ICE or two.

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list