ARM gnueabi NPTL/TLS GCC 4.1.1 glibc 2.5

Michael K. Edwards m.k.edwards@gmail.com
Tue Dec 5 04:35:00 GMT 2006


On 12/4/06, Bridge Wu <mingqiao.wu@gmail.com> wrote:
> I have built an ARM EABI tool chain with gcc-4.1.1 and glibc-2.5 for
> xscale. However, it used kernel-2.6.14 with applying EABI patches
> manually. It works fine to build kernel and userland applications. It
> also works fine with qtopia-free-2.2.0.

Have you built your kernel with support for OABI userland binaries?
Do you happen to know in what kernel (and/or with what patches) OABI
compatibility began to work?  I ask because there are a couple of
vendor-supplied binaries that I am not likely to get in an EABI build
immediately.

Cheers,
- Michael

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list