Failure to boot into cross built environment

Steven Newbury s_j_newbury@yahoo.co.uk
Sun Apr 23 08:00:00 GMT 2006


OK this is now confirmed.  I tried turning on oldabi support and booting into
another rootfs. That worked. Chrooting into my EABI environment gave the error
below.

--- Steven Newbury <s_j_newbury@yahoo.co.uk> wrote:

> Sorry just ignore me for now... I've just realised that I've got a problem
> flashing the jffs2 root filesystem and it was trying to boot an old rootfs...
> 
> --- Steven Newbury <s_j_newbury@yahoo.co.uk> wrote:
> 
> > I'm not entirely sure where I should be sending this, but oh well.  As
> things
> > stand I have cross-built a minimal Gentoo environment for
> iWMMXTt-EABI-NPTL,
> > I
> > have flashed everything onto my Zaurus SL-C3100 but run into a new problem.
> > 
> > On booting I get run running init/bash:
> > 
> > Inconsistency detected by ld.so: dl-minimal.c :84: __libc_memalign:
> Assertion
> > `page != ((void *) -1)' failed!
> > 
> > I'm going to build a static sh and see if I can get it at least
> interactive.
> > 
> > I have built all the userspace with -march=iwmmxt -mcpu=iwmmxt -mabi=aapcs,
> > and
> > the kernel with EABI (-mabi=aapcs) and CONFIG_IWMMXT but without old ABI
> > support.

I'm not sure which list to take this to since I'm not sure where the problem
is.  I will try arm-linux-kernel tomorrow.  If anybody has any ideas please
speak up! :-)


Steve


		
___________________________________________________________ 
Switch an email account to Yahoo! Mail, you could win FIFA World Cup tickets. http://uk.mail.yahoo.com

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list