Failure to boot into cross built environment

Steven Newbury s_j_newbury@yahoo.co.uk
Sun Apr 23 05:24:00 GMT 2006


Sorry just ignore me for now... I've just realised that I've got a problem
flashing the jffs2 root filesystem and it was trying to boot an old rootfs...

--- Steven Newbury <s_j_newbury@yahoo.co.uk> wrote:

> I'm not entirely sure where I should be sending this, but oh well.  As things
> stand I have cross-built a minimal Gentoo environment for iWMMXTt-EABI-NPTL,
> I
> have flashed everything onto my Zaurus SL-C3100 but run into a new problem.
> 
> On booting I get run running init/bash:
> 
> Inconsistency detected by ld.so: dl-minimal.c :84: __libc_memalign: Assertion
> `page != ((void *) -1)' failed!
> 
> I'm going to build a static sh and see if I can get it at least interactive.
> 
> I have built all the userspace with -march=iwmmxt -mcpu=iwmmxt -mabi=aapcs,
> and
> the kernel with EABI (-mabi=aapcs) and CONFIG_IWMMXT but without old ABI
> support.
> 
> 
> Steve
> 
> 
> 		
> ___________________________________________________________ 
> NEW Yahoo! Cars - sell your car and browse thousands of new and used cars
> online! http://uk.cars.yahoo.com/
> 
> --
> For unsubscribe information see http://sourceware.org/lists.html#faq
> 
> 


Steve


		
___________________________________________________________ 
Switch an email account to Yahoo! Mail, you could win FIFA World Cup tickets. http://uk.mail.yahoo.com

--
For unsubscribe information see http://sourceware.org/lists.html#faq



More information about the crossgcc mailing list