previous working build for SH3 now fails

Dave Korn dave.korn@artimi.com
Tue Sep 6 13:56:00 GMT 2005


----Original Message----
>From: Robert P. J. Day
>Sent: 06 September 2005 14:06

>   without getting into gruesome detail, i grabbed crosstool-0.38 and
> did a "demo-sh3.sh" build, which failed and i'm guessing it's because
> i'm doing this on a fully-updated FC4 box running gcc-4.0.1.
> 
>   i'm guessing it's because gcc-4 is a much less forgiving compiler
> when it comes to questionable programming constructs and i'm wondering
> how many previously working combinations aren't going to work anymore
> under gcc-4.  (it's well known how lots of compiles that used to work
> everywhere don't under gcc-4.)
> 
>   or perhaps this is something entirely different.  i can post the
> actual errors if someone wants to peruse them.

  I can't help but ask, what on earth was the point of making a post
_without_ the errors?

  "It failed" isn't a problem description that anyone can do anything with,
and your speculation on what might have caused it isn't exactly any use to
anyone when it comes without the slightest piece of information that might
help them to confirm or deny your guesswork.  If you don't say what the
error _is_, how is anyone meant to know whether the updated compiler could
have caused it or not?

  You should maybe take a browse through the helpful advice posted at 
http://www.catb.org/~esr/faqs/smart-questions.html
  and
http://www.chiark.greenend.org.uk/~sgtatham/bugs.html
before reposting.

    cheers,
      DaveK
-- 
Can't think of a witty .sigline today....


------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com



More information about the crossgcc mailing list