build error for sh4 using latest snapshot of gcc

Robert P. J. Day
Wed Oct 19 19:10:00 GMT 2005

On Wed, 19 Oct 2005, Dan Kegel wrote:

> Robert P. J. Day wrote:
> > > >
> > >
> > > Thanks!  But to really count, the bug report needs a preprocessed
> > > source file
> >
> > i understand that, but that's asking a lot of someone (i.e., me) who's
> > still figuring his way around here to dig into the glibc source and
> > try to construct from that a single source file that generates the
> > same error that crosstool produced.
> Yeah.  But really, it's not that hard!  In fact, it's kind of mechanical!
> Here's what you do:
> 1. Run the build and save a log file.
> 2. Look at the log to figure out what directory the failed command was run in
> 3. Look at the log to find what PATH was set to
> 4. Create a three-(long-)line shell script that sets the PATH,
>    cd's to the directory, and runs the failed command
>    (in this case, the monster long gcc command that starts with
>      sh4-unknown-linux-gnu-gcc  ../sysdeps/generic/strtok.c
>     and ends with
>      -MT
>     /home/rpjday/ct/
> )
> 5. Verify that this shell script reproduces the problem
>    It should take about one or two seconds to run
> 6. Modify the command by adding the -save-temps option
> 7. Run it again
> 8. Voila, you should have a strtok.i file ready to compress and upload as an
>    attachment to your bug!

ok, that worked, and the corresponding strtok.i.gz file is now
attached to the bug report.


Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

More information about the crossgcc mailing list