GCC-4.0.2 on Cygwin

Brian Rose lists@brianrose.net
Sun Oct 9 02:29:00 GMT 2005

Brian Rose wrote:

> Brian Dessent wrote:
>> Brian Rose wrote:
>>> Note: I am an embedded developer who has spent the better part of 10 
>>> years
>>> doing VxWorks and a little WinCE. So feel free to get technical. Its 
>>> just
>>> that I am relatively inexperienced with open source software on the 
>>> Cygwin
>>> platform and I am not used to having to build my own tools.
>> Try running the failing gcc command with -v to see what it's doing.  Is
>> it calling the correct 'as'?
> I added a -v to the FLAGS_FOR_TARGET and I see the following line before 
> the error now,
> /home/brose/rtems/tools/m68k-elf/bin/as.exe -m68040 -o 
> libgcc/m68040/_fixunsdfsi.o 
> /cygdrive/c/DOCUME~1/brose/LOCALS~1/Temp/ccghXdpv.s
> So it looks like the correct assembler is being called. But then I do 
> 'as --version' and I see that "This assembler has been configured for a 
> target of 'i686-pc-cygwin'. So it looks like when I built my binutils, 
> it made the incorrect as.
> How do I point GCC to the correct as? I'm guessing there is a configure 
> option?

OK here is where I get all confused. I am building a gcc in order to use 
that gcc to build m68k-elf programs. So when I am building the gcc, my 
target *should* be i686-pc-cygwin, correct? Because this gcc that I am 
building will *run* on my Cygwin PC.

I have a process which I worked out which I am trying to update. This 
worked for binutils 2.15 and gcc 3.4.2. I just want to update it to the 
current tools, and I am getting these errors.

You can see the old process at 



Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com

More information about the crossgcc mailing list