m68k fails to build with crosstool

Steve Papacharalambous stevep@zee2.com
Wed Oct 27 13:47:00 GMT 2004

Hi Peter,

Sorry, I forgot to mention that I didn't delete the existing autoconf 
and binutils, but installed the new versions in /usr/local/bin on the 
build machine, and changed PATH to make sure that the new versions were 
picked up when I ran crosstool,

Best regards,


Steve Papacharalambous wrote:
> Hi Peter,
> It looks like the version of binutils and autoconf on your build host 
> are too old and need upgrading.
> I had a similar problem and fixed it by upgrading binutils to 
> binutils-2.15 and autoconf to autoconf-2.59,
> Best regards,
> Steve
> Peter Barada wrote:
>> Dan,
>> I'm trying to whip together a toolchain using crosstoo-0.28-rc37 on my
>> x86 RH 7.3 machine.  I have a native gcc-3.3 compiler in the path.
>> I modified demo-m68k.sh to have the line:
>> eval `cat m68k.dat gcc-3.4.2-glibc-2.3.3.dat` sh all.sh --notest
>> in an attempt to build a gcc-3.4.2 compiler and glibc-2.3.3, but it
>> fails in the build-glibc-headers configure step:
>> + 
>> /home/peter/work/cvs-private/private/x-linux-tools/crosstool-0.28-rc37/build/m68k-unknown-linux-gnu/gcc-3.4.2-glibc-2.3.3/glibc-2.3.3/configure 
>> --prefix=/usr --build=i686-pc-linux-gnu --host=m68k-unknown-linux-gnu 
>> --without-cvs --disable-sanity-checks 
>> --with-headers=/home/mylocal/crosstool/m68k-unknown-linux-gnu/gcc-3.4.2-glibc-2.3.3/m68k-unknown-linux-gnu/include 
>> --enable-hacker-mode
>> checking build system type... i686-pc-linux-gnu
>> checking host system type... m68k-unknown-linux-gnu
>> checking sysdep dirs... sysdeps/m68k/elf sysdeps/unix/sysv/linux/m68k 
>> sysdeps/unix/sysv/linux sysdeps/gnu sysdeps/unix/common 
>> sysdeps/unix/mman sysdeps/unix/inet sysdeps/unix/sysv sysdeps/unix 
>> sysdeps/posix sysdeps/m68k/m68020 sysdeps/m68k/fpu sysdeps/m68k 
>> sysdeps/wordsize-32 sysdeps/ieee754/ldbl-96 sysdeps/ieee754/dbl-64 
>> sysdeps/ieee754/flt-32 sysdeps/ieee754 sysdeps/generic/elf 
>> sysdeps/generic
>> checking for a BSD-compatible install... /usr/bin/install -c
>> checking whether ln -s works... yes
>> checking for m68k-unknown-linux-gnu-gcc... gcc
>> checking for suffix of object files... o
>> checking whether we are using the GNU C compiler... yes
>> checking whether gcc accepts -g... yes
>> checking for gcc option to accept ANSI C... none needed
>> checking for gcc... gcc
>> checking how to run the C preprocessor... gcc -E
>> checking for m68k-unknown-linux-gnu-g++... no
>> checking for m68k-unknown-linux-gnu-c++... no
>> checking for m68k-unknown-linux-gnu-gpp... no
>> checking for m68k-unknown-linux-gnu-aCC... no
>> checking for m68k-unknown-linux-gnu-CC... no
>> checking for m68k-unknown-linux-gnu-cxx... no
>> checking for m68k-unknown-linux-gnu-cc++... no
>> checking for m68k-unknown-linux-gnu-cl... no
>> checking for m68k-unknown-linux-gnu-FCC... no
>> checking for m68k-unknown-linux-gnu-KCC... no
>> checking for m68k-unknown-linux-gnu-RCC... no
>> checking for m68k-unknown-linux-gnu-xlC_r... no
>> checking for m68k-unknown-linux-gnu-xlC... no
>> checking for g++... g++
>> checking whether we are using the GNU C++ compiler... yes
>> checking whether g++ accepts -g... yes
>> checking for m68k-unknown-linux-gnu-ranlib... 
>> m68k-unknown-linux-gnu-ranlib
>> checking whether as is GNU as... yes
>> checking whether ld is GNU ld... yes
>> checking for as... as
>> checking version of as..., bad
>> checking for ld... ld
>> checking version of ld..., bad
>> checking for pwd... /bin/pwd
>> checking for m68k-unknown-linux-gnu-gcc... (cached) gcc
>> checking version of gcc... 3.3, ok
>> checking for gnumake... no
>> checking for gmake... gmake
>> checking version of gmake... 3.79.1, ok
>> checking for gnumsgfmt... no
>> checking for gmsgfmt... no
>> checking for msgfmt... msgfmt
>> checking version of msgfmt... 0.11.1, ok
>> checking for makeinfo... makeinfo
>> checking version of makeinfo... 4.1, ok
>> checking for sed... sed
>> checking version of sed... 3.02, ok
>> checking for autoconf... autoconf
>> checking whether autoconf works... no
>> configure: error:
>> *** These critical programs are missing or too old: as ld
>> *** Check the INSTALL file for required versions.
>> Any suggestions on how to proceed get around this error?
>> I'm wondering if I need to create a new native binutils and put that
>> in my path(as well as the compiler), and *then* attempt to run
>> crosstool...

Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com

More information about the crossgcc mailing list