crosstools cygwin woes

bertrand marquis bertrand_marquis@yahoo.fr
Mon Jun 28 07:11:00 GMT 2004


Michael Miller a écrit:

>>>Michael D. Miller wrote:
>>>I'm trying to run crosstools 0.28-rc25 under Cygwin.  I'm running under
>>>Windows XP with the latest Cygwin files.  My target is a SH4.  The
>>>initial tools build completes without any errors, but when I try to run
>>>a make menuconfig I get a signal 11 in ld.  Relevant configuration
>>>information is gcc version 3.4.0, glib version 2.3.2, kernel version
>>>2.6.6 and ld version 2.15.90.  Ld terminates in scripts/kconfig/mconf
>>>with a STATUS_ACCESS_VIOLATION.  I've tried updating the native gcc to
>>>3.4.0 and checked to make sure I had the latest binutils.  Does anyone
>>>have any ideas how to get menuconfig to run or what I might be doing
>>>wrong?
>>>      
>>>
>
>  
>
>>Dan Kegel wrote:
>>First things first: don't call it glib, it's *glibc* :-)
>>
>>Second, look for the posting from asheth at ixiacom.com in the archive
>>a week or two ago, June 15.  They tested with
>>
>>    - gcc 3.3.3
>>	- glibc 2.3.2
>>	- binutils 2.15
>>	- Linux kernel headers 2.6.6
>>
>>Please give that a try.
>>
>>Third, I read recently of trouble building the linux
>>kernel under cygwin.  I don't recall where I heard it,
>>or whether a patch was available.
>>Be sure to check the linux-sh mailing lists.
>>- Dan
>>    
>>
>
>OK - gcc 3.3.3 and 2.4.24 menuconfig works.  Gcc 3.3.3 and 2.6.6 fails.  I'm
>not sure based on his email that Ankur actually ran menuconfig.  Maybe Ankur
>could give it a quick try or let us know if it worked for him?
>
>My failure from 3.3.3 is slightly different.
>
>$ make menuconfig
>  HOSTCC  scripts/basic/fixdep
>  HOSTCC  scripts/basic/split-include
>  HOSTCC  scripts/basic/docproc
>  HOSTLD  scripts/kconfig/mconf
>collect2: ld terminated with signal 11 [Segmentation fault], core dumped
>scripts/kconfig/libkconfig.so(.text+0x0):crtstuff.c: multiple definition of
>`___do_sjlj_init'
>/usr/lib/gcc-lib/i686-pc-cygwin/3.3.1/crtbegin.o(.text+0x0):crtstuff.c:
>first defined here
>make[1]: *** [scripts/kconfig/mconf] Error 1
>make: *** [menuconfig] Error 2
>
>I tried some other things like make depend and had other issues like
>argument list line length.  I think I'll just abandon Cygwin for now and go
>back to Mandrake.
>
>	Thanks,
>	Mike 
>
>
>------
>Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
>Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com
>
>
>  
>
Hello,

    I had the same problem last week. It seems that mconf is linked 
using a .so file. I had to change this to link mconf with the .o file. I 
also had problems because to compile the kconfg_elk or something like 
that program in script/, we need elf.h header. I solve that using the 
libelf to have a elf.h under cygwin.
here is what i'm using:

gcc 3.2.3
glibc 2.3.2
binutils 2.14
kernel 2.6.7 (but the patch is also good for 2.6.6)

here is the patch i'm trying to use now, i'm still under progress for 
kernel 2.6.7 so i don't know if everything else will work:

--- linux-x86-2.6.7/scripts/kconfig/Makefile    2004-06-16 
07:20:26.000000000 +0200
+++ linux-x86-2.6.7.cyg/linux-x86-2.6.7/scripts/kconfig/Makefile    
2004-06-24 10:39:18.824400000 +0200
@@ -68,8 +68,8 @@
 libkconfig-objs := zconf.tab.o
 
 host-progs    := conf mconf qconf gconf
-conf-objs    := conf.o  libkconfig.so
-mconf-objs    := mconf.o libkconfig.so
+conf-objs    := conf.o  libkconfig.o
+mconf-objs    := mconf.o zconf.tab.o
 
 ifeq ($(MAKECMDGOALS),xconfig)
     qconf-target := 1
@@ -89,11 +89,12 @@
 endif
 
 clean-files    := libkconfig.so lkc_defs.h qconf.moc .tmp_qtcheck \
-           .tmp_gtkcheck zconf.tab.c zconf.tab.h lex.zconf.c
+           .tmp_gtkcheck zconf.tab.c zconf.tab.h lex.zconf.c libkconfig.o
 
 # generated files seem to need this to find local include files
 HOSTCFLAGS_lex.zconf.o    := -I$(src)
 HOSTCFLAGS_zconf.tab.o    := -I$(src)
+HOSTCFLAGS_libkconfig.o    := -I$(src)
 
 HOSTLOADLIBES_qconf    = -L$(QTLIBPATH) -Wl,-rpath,$(QTLIBPATH) 
-l$(QTLIB) -ldl
 HOSTCXXFLAGS_qconf.o    = -I$(QTDIR)/include
@@ -101,6 +102,9 @@
 HOSTLOADLIBES_gconf    = `pkg-config gtk+-2.0 gmodule-2.0 libglade-2.0 
--libs`
 HOSTCFLAGS_gconf.o    = `pkg-config gtk+-2.0 gmodule-2.0 libglade-2.0 
--cflags`
 
+$(obj)/libkconfig.c: $(obj)/zconf.tab.c $(obj)/lex.zconf.c
+    cp $< $@
+
 $(obj)/conf.o $(obj)/mconf.o $(obj)/qconf.o $(obj)/gconf.o: 
$(obj)/zconf.tab.h
 
 $(obj)/qconf.o: $(obj)/.tmp_qtcheck

Best Reagards

Bertrand


------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com



More information about the crossgcc mailing list