crosstools cygwin woes

Dan Kegel dank@kegel.com
Sat Jun 26 03:16:00 GMT 2004


Michael D. Miller wrote:
> I'm trying to run crosstools 0.28-rc25 under Cygwin.  I'm running under
> Windows XP with the latest Cygwin files.  My target is a SH4.  The
> initial tools build completes without any errors, but when I try to run
> a make menuconfig I get a signal 11 in ld.  Relevant configuration
> information is gcc version 3.4.0, glib version 2.3.2, kernel version
> 2.6.6 and ld version 2.15.90.  Ld terminates in scripts/kconfig/mconf
> with a STATUS_ACCESS_VIOLATION.  I've tried updating the native gcc to
> 3.4.0 and checked to make sure I had the latest binutils.  Does anyone
> have any ideas how to get menuconfig to run or what I might be doing
> wrong?

First things first: don't call it glib, it's *glibc* :-)

Second, look for the posting from asheth at ixiacom.com in the archive
a week or two ago, June 15.  They tested with

         - gcc 3.3.3
	- glibc 2.3.2
	- binutils 2.15
	- Linux kernel headers 2.6.6

Please give that a try.

Third, I read recently of trouble building the linux
kernel under cygwin.  I don't recall where I heard it,
or whether a patch was available.
Be sure to check the linux-sh mailing lists.
- Dan

-- 
My technical stuff: http://kegel.com
My politics: see http://www.misleader.org for examples of why I'm for regime change

------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com



More information about the crossgcc mailing list