i386 target toolchain problem (i686 host)

Paul Taylor ptaylor.engineer@virgin.net
Thu Jun 24 09:43:00 GMT 2004


I am attempting to build an i386 toolchain (gcc-3.3.3, glibc-2.3.2,
binutils-2.14) on my i686 host (tried RH9 and FC1). 

I have a problem building glibc-2.3.2 with a core i386-linux-gcc.  I get
the error message:

libc.so.lds:112: parse error

When I look in libc.so.lds, there are error messages such as:

tools/lib/gcc-lib/i386-linux/3.3.3/libgcc.a(unwind-dw2-fde-glibc.o)(.text+0x32): In function `size_of_encoded_value':
../../gcc-3.3.3/gcc/unwind-pe.h:76: undefined reference to `abort'

and similar undefined references to malloc and free.

I have found some references using google, but can't quite stumble on a

I an attempt to get past this problem, I decided to give crosstool.sh a
go with environment variables set as follows:

export PREFIX=/opt/cross/tools
export BUILD_DIR=/opt/cross/build
export BINUTILS_DIR=binutils-2.14
export GCC_DIR=gcc-3.3.3
export GLIBC_DIR=glibc-2.3.2
export LINUX_DIR=linux-2.4.26
export TARGET=i386-linux

But alas, I get exactly the same error.

I'm not sure if its possible to run crosstool.sh like this?  I am just
going through the rest of the crosstool scripts (demo.sh, all.sh, ...)
to figure out what else its doing, as it seems to do more than what I
would like (at least, that is what I'm thinking at the moment), as it
try's to connect to the internet to do something (haven't yet worked out
what - still going through the scripts/docs).  My thinking at the moment
is to download/unpack the sources myself, apply any patches myself, and
then build - so that I know exactly what's going on.  

The only patch I have applied is the sscanf.patch to glibc-2.3.2.  All
other sources are as downloaded.  

Any hints greatly appreciated. 



Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com

More information about the crossgcc mailing list