redid per your advise - see some progress, however got

Povolotsky, Alexander
Wed Jul 28 16:47:00 GMT 2004


I started with a newly-unpacked linux-2.6.7 tree per your advise and
reinstalled your patch.

(Also made changes as was instructed before to avoid using shared libraries,
of course; also handling of elf.h -> gelf.h is still in place ..)

Also installed patch-2.6.8-rc2 - did you try it yourself ?

The problem with not finding arch/ppc/kernel/asm-offsets.asm went away as
you have predicted (in your e-mail below)!

But now I see `CONFIG_KERNEL_START' and `CONFIG_TASK_SIZE' undeclared while
doing  "make ARCH=ppc prepare" (after "make menuconfig" - I noticed new
configurational options brought by patch-2.6.8-rc2 - I used default "No" on
those, I think)

apovolot@USPITLAD104868 ~/linux-2.6.8-rc2/linux-2.6.7
$ make ARCH=ppc prepare
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/basic/split-include
  HOSTCC  scripts/basic/docproc
  HOSTCC  scripts/conmakehash
  HOSTCC  scripts/kallsyms
  CC      scripts/empty.o
  HOSTCC  scripts/mk_elfconfig
  MKELF   scripts/elfconfig.h
  HOSTCC  scripts/file2alias.o
  HOSTCC  scripts/modpost.o
  HOSTCC  scripts/sumversion.o
  HOSTLD  scripts/modpost
  HOSTCC  scripts/pnmtologo
  HOSTCC  scripts/bin2c
  SYMLINK include/asm -> include/asm-ppc
  CHK     include/linux/version.h
  UPD     include/linux/version.h
  CC      arch/ppc/kernel/asm-offsets.asm
In file included from include/linux/mman.h:5,
                 from arch/ppc/kernel/asm-offsets.c:19:
include/linux/mm.h: In function `lowmem_page_address':
include/linux/mm.h:406: error: `CONFIG_KERNEL_START' undeclared (first use
in th
is function)
include/linux/mm.h:406: error: (Each undeclared identifier is reported only

include/linux/mm.h:406: error: for each function it appears in.)
In file included from arch/ppc/kernel/asm-offsets.c:21:
include/asm/io.h: In function `virt_to_bus':
include/asm/io.h:230: error: `CONFIG_KERNEL_START' undeclared (first use in
include/asm/io.h: In function `bus_to_virt':
include/asm/io.h:241: error: `CONFIG_KERNEL_START' undeclared (first use in
include/asm/io.h: In function `virt_to_phys':
include/asm/io.h:254: error: `CONFIG_KERNEL_START' undeclared (first use in
include/asm/io.h: In function `phys_to_virt':
include/asm/io.h:263: error: `CONFIG_KERNEL_START' undeclared (first use in
arch/ppc/kernel/asm-offsets.c: In function `main':
arch/ppc/kernel/asm-offsets.c:132: error: `CONFIG_TASK_SIZE' undeclared
(first u
se in this function)
make[1]: *** [arch/ppc/kernel/asm-offsets.asm] Error 1
make: *** [arch/ppc/kernel/asm-offsets.asm] Error 2

-----Original Message-----
From: Martin Schaffner []
Sent: Tuesday, July 27, 2004 2:31 PM
To: Povolotsky, Alexander
Subject: Re: Thanks ! - Re: powerpc-linux-ld problems

On 27.07.2004, at 09:49, Povolotsky, Alexander wrote:

> Martin - Thanks !
> One more question - Sorry - I am new in Linux ... is there any Linux 
> command (script) I could run on Cygwin shell to integrate your patches
into the
> source prior to building - or is it only could be done manually ?

I don't know of any - but if it is just for this one patch, you can 
write one yourself...

> Tried to use -p1 option with the patch command - it seems to be worked.
> But subsequent make zimage failed with:  "cannot open
> arch/ppc/kernel/asm-offsets.asm: no such file"
> apovolot@USPITLAD104868 ~/linux-2.6.7
> $ patch -p1 < linux-2.6.7-build_on_case_insensitive_fs-1.patch
> patching file Makefile
> Reversed (or previously applied) patch detected!  Assume -R? [n] y

You shouldn't need to reverse anything...

OK, Start with a newly-unpacked linux-2.6.7 tree, delete you current 
one, which is broken. This should solve your problems!
BTW, "-p1" is a pretty standard requirement, you'll need it for most 
patches you'll ever see...

Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

More information about the crossgcc mailing list