About to crosstool-0.27..

Dan Kegel dank@kegel.com
Sat Jul 10 06:54:00 GMT 2004


Yongdae,Shin wrote:
> My name is Yongdae, Shin.
> I'm a Korea Student which have interested embedded linux system.
> 
> At this time, i build the cross compile develop environment.
> I will use the Samsung SMDK2410TK board for Samsung S3C2410X(ARM920T) CPU.
> 
> Successfully, I have complete the cross toolchain build.
> But, I have failed compile to Linux Kernel 2.4.18.
> 
> ...
> blkpg.c: In function `blk_ioctl':
> blkpg.c:250: error: asm-specifier for variable `__r1' conflicts with asm
> clobber list

That's a known problem with the Linux kernel source.
You probably can find a version that has been fixed.
See e.g.
http://sources.redhat.com/ml/crossgcc/2004-05/msg00147.html

Please address future questions about crosstool
to the crossgcc mailing list.

Also, you probably want to use crosstool-0.28-rc28 or later
rather than 0.27.

Good luck!
- Dan

-- 
My technical stuff: http://kegel.com
My politics: see http://www.misleader.org for examples of why I'm for regime change

------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com



More information about the crossgcc mailing list