testing uClibc patch

libber libber@AtlasWebmail.com
Tue Jan 6 08:21:00 GMT 2004

Ok sorry for the confusion from my last post, I do in fact have
the relocate perl script I just forgot to delete that point before
I sent. Also I think its much more likley that I am incorrectly
applying your patches or something as opposed to your patches
being wrong, so I was wondering, can you successfully build a
mipsel-uclibc cross compiler with your patches applied?

Firstly I should ask what is the correct way to apply patches
for uclibc? I made a directory called 'uClibc-0.9.23' and put
the patches in there but they seem to have not been applied,
I am now building agian after copying that directory to 'uclibc-0.9.23'
after noticing everything else in patches was in lower case.

Secondly I have applied your patchesbut I still die on the same
error as before even with having two copies of the directories
as stated above. The other thing I realized is that uclibc config
prompts me for only one option during the crosstools build (should
this happen? me being prompted for uclibc config options that
is) which is something like add locale support or something.
I always say no to this test but I get the same thing even if
I select yes.
error: cannot convert `const __ctype_touplow_t*' to `const int*'
in assignment"

Thirdly I should share what I know about the linksys wrt54g in
hopes of saving others time even though it is not really relevant
now. I have tried to get the linksys-provided compiler (http://www.linksys.com/support/gpl.asp)
to bend to my will but it has not been working so great. In that
package they give gcc 3.0, this gcc works ok but the g++ they
provide does not work very well. I don't have my list with me
of what works with the compilers but I recall that you can compile
c++ and it will compile and link agianst their version of uClibc
( 0.9.19) but threads don't work  and you have to compile staticially
as I recall (threads and -static simply don't work, even in x86
- who knew?)  some another things I need. As far as straight
C goes thier gcc compiles just fine but gives wierd errors upon
execution, f.e I made a simple pthreads program with the uclibc-gcc
and when I ran it on the linksys I get a SIGSEV. Wierd and important
errors like this are common and I can provide more if desired.
The key thing is that they have some modifications for thier
gcc so once we get a cross-compiling uclibc mipsel gcc we might
need to add these modifications. I have sent linksys an email
asking if they have gotten c++ and threads to work and have not
yet heard back. Oh also I should be explicit and say that the
linksys hardware itself uses only uclibc even though they have
a glibc directory in thier tarball, this messed me up for a few

Thanks for your time,

- - - - - - - - - - - - - - - - - - - -
  The internet's 2nd-best-kept secret:

Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com

More information about the crossgcc mailing list