some confusion w/ crosstool-0.28-rc37

Dan Kegel
Sun Dec 12 16:14:00 GMT 2004

Jay Moore wrote:
> On Sun, 2004-12-12 at 03:08, Jay Moore wrote:
> So I d/l the tarball into /home/jamoore/crosstool & commented all the
> architectures except "" in ''. I created a dir named
> '/opt/crosstool', and chown'd it to jamoore. Then I ran ''
> After some time, the command prompt came back, and I perused the file
> 'demo-i686.log' to see how things went. The closing lines from this file
> are shown below... 
>   + echo Cross-toolchain build complete. Result in /home/jamoore/emb/tools.
> it looked like a success. However, when I ran
> '', it exited & closed the terminal. is not meant to be run standalone; it requires you
to set PREFIX.  It's already run by demo-*.sh, so you don't really
need to run it yourself; if it fails, it will leave an error message
at the end of the demo-*.sh output.

> This must sound awfully stupid... the only thing I can figure is that
> some of the environment variables I set up during my attempts to
> manually build a toolchain got picked up by the crosstool shell.
> Any suggestions on how to untangle this rat's nest I've created? Can I
> just rm -r /home/jamoore/emb, and /home/jamoore/crosstool, reboot and
> start over?

What you saw could have been caused by setting PREFIX to /home/jamoore/emb/tools.

Here's what I'd suggest:
Clear any environment variables you set earlier (e.g. by logging out and then in again),
then verify that PREFIX is not set (e.g. env | grep PREFIX should be empty),
then run

   cd /home/jamoore
   rm -rf emb/tools
   cd crosstool
   rm -rf build > log 2>&1 &
   tail -f log

( is kind of silly, and I may as well delete it from the next release.)
- Dan

Trying to get a job as a c++ developer?  See

Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

More information about the crossgcc mailing list