some confusion w/ crosstool-0.28-rc37

Jay Moore
Sun Dec 12 09:08:00 GMT 2004

I wasn't having much luck resolving my problem(s) in manually building a
toolchain (using Yaghmour's book as a guide), so I thought I try the
"easy way" - d/l crosstool  :)

So I d/l the tarball into /home/jamoore/crosstool & commented all the
architectures except "" in ''. I created a dir named
'/opt/crosstool', and chown'd it to jamoore. Then I ran ''

After some time, the command prompt came back, and I perused the file
'demo-i686.log' to see how things went. The closing lines from this file
are shown below... it looked like a success. However, when I ran
'', it exited & closed the terminal.

I then looked at '/opt/crosstool' - it was empty (nothing had been added
to it). Looking back at 'demo-i686.log' I noticed a lot of activity in 
/home/jamoore/emb/tools. Hmmm - appears this is where all the results of
running were placed!!

This must sound awfully stupid... the only thing I can figure is that
some of the environment variables I set up during my attempts to
manually build a toolchain got picked up by the crosstool shell.

Any suggestions on how to untangle this rat's nest I've created? Can I
just rm -r /home/jamoore/emb, and /home/jamoore/crosstool, reboot and
start over?


Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

More information about the crossgcc mailing list